"App Inventor is unable to compile this project." Error may be caused by: → Project in a project

Here is a guide (video instructions) on how to fix the problem that a project cannot be compiled:

"App Inventor is unable to compile this project."

Possible reason: there is a project in a project.
Caused by an extension that was imported from another AppInventor clone (here: AppyBuilder).

This issue is now also increasingly reported in App Inventor, e.g. here: My app is getting server issues and here: Unable to build apk!

See here how to fix this:


(added to FAQ)

1 Like

5 posts were split to a new topic: App Inventor is unable to compile this project. The compiler error output was

it doesn't work for me I don't know how to do it I tried and tried again you don't have any other ideas

Post the aia.

4 posts were split to a new topic: DX execution failed error

Hi there, I followed this post but the project still fails to compile.

Please check the attached aia file.


ps. I tried to upload the aia file in this forum but failed.

You have another project in your project:

1 Like

Try this, removed project within project

ACE_app_1.aia (5.1 MB)

1 Like

See the video here:

In screen recipes_screen there was also a duplicate declaration of when start1 click, which also led compile to fail. Removed from above aia



1 Like

Thanks for your quick response.

This __MACOSX folder was accidentally added by MacOS's compression util.

Thanks, this app works like a charm now.

1 Like

@Anke I tried your video but it is not working. Kindly help me.
Smart_Locker_v1_mod (1).aia (1.3 MB)