Problem signing APK, YAIL compiler > apksigner execution failed

Hello everybody. I’m new at APP Inventor and I’m really pleased with the ease of use. I just created an app that I needed and it is working!!!

The problem is that when I build the APK at the end it gives the error i mentionned.

The keystore I created earlier was used with another attempt, the same project actually but with a software called " Website to APK builder pro" that simply embeds a website in a APK. The keystore was accepted by the software so I figure that it is working. Now I imported that same keystore file in here and when building the APP it gives an error. Should I use a different file or it should work? Actually so it worked with the former software I had to convert it to a different encoding. From RSA to PKCS12 or something like this. Thanks in advance for your help and Want to say I’m really glad I have come to meet you people!!! Bruno

Have you read this Bruno.

App Inventor creates its own keystore file. I understand using the keystore from a previous app that you make with a different compiler will not work. You cannot take a keystore from another app and ‘give’ it to your new app created with App Inventor. See the posts from the old Forum about using a keystore.


Waw, i deleted it and now it works. Exported it so there is no problem in future. Thanks a lot Steve

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.