I have an error with bluetooth on android 12, Xiaomi Poco X3 NFC

Have you removed permission requests from your aia, from blocks?

I'm sorry to say this but I don't know how to make that

Put your aia project here. Maybe we started the whole diagnostics wrong.

here it is
BracoRobo.aia (1.7 KB)

I found it:

This seems to be a problem with xiaomi.

Try it:
BracoRobo.aia (1.8 KB)

No manifest change.

I added a block:

It worked, thank you

So xiaomi even though it has android12 still requires old permissions. From what I've read, the BLUETOOTH and BLUETOOTH_ADMIN permissions should not cause problems in android12, only google can get stuck after sending such an app to google play.

It's particularly problematic because the old Bluetooth permissions aren't even runtime permissions, so there should never be a need to use the "AskForPermission" block to obtain them.

From what I've read, Xiaomi has something broken with bluetooth permissions. And it's strange that it worked here.



Add this block:



When calling bluetoothle1. startscan, the APP calls location information instead of Bluetooth.

This topic is about bluetooth classic, not bluetooth le.

I encountered the same problem as this

Use the latest version of the ble extension from this year. Yesterday I share a link in two topics about ble.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.