ListPicker Not Showing Bluetooth Devices with an Arduino Uno R3

Good evening, I am relatively new to the MIT App Inventor. For my project, I want to connect an Arduino Uno R3 to the software and display the values of the sensors on the app. However, when I run the app on my phone to test it, the ListPicker does not show any devices although I have the Bluetooth activated and the HC-06 Bluetooth module paired to my phone. I have reset my computer and phone, used different devices, tried different connections, but still no solution. For the coding portion, I used a ListPicker and the BluetoothClient. Thank you in advance!

This is the code I used

Newer Androids require permissions to scan and connect. For more details, please use the search engine in our community. Almost every day someone asks this....

(Canned Response ABG - Bluetooth non-BLE SCAN Permission Blocks)

The easiest solution, for immediate relief
(from @Barry_Meaker) ...

I had the same issue. The problem is your app does not have permission to see nearby devices. The solution is to give your app permission on your phone (no code changes in your app).

on your phone,

  • goto settings
  • search for your app
  • in App Info for your app select Permissions
  • change Nearby Devices from Not Allowed to Allowed
  • Done

By the way, the very first time you run the app, Android will ask if you want to grant the app this permission. If you say no, or ignore the pop-up, the permission will be set as Denied. Android will not ask again.

A more complex approach, for professional app development:

See Bluetooth liste of devices deosn't work anymore - #7 by Anke
Special note for Xiaomi devices:
I have an error with bluetooth on android 12, Xiaomi Poco X3 NFC - #20 by Patryk_F

Thank you so much for your help, I was able to get the problem fixed.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.