App inventor is unable to compile this project.(XML,SAXParseException;);lineNumber1;columnNumber:4155; An invalid XML character(Unicode: 0x8) was found in the element content of the document.

Now this is the error message I get when I try to build my project to apk file. I tried to find where the lineNumber 1, columNumber 4155 by using Android Studio, Visual Studio code, but I can't find the scripte that is long enough over 4155.

Maybe my approach to this problem was wrong from the beginning. So.. Any advice?

Unicode 0x8 is the backspace character. Maybe your aia got damaged. Could you post it here?

(Canned Reply: ABG- Export & Upload .aia)
Export your .aia file and upload it here.

I had same problem on my project.
so, I've tried to export my project as aia file.
and then rename *.aia to *.zip to extract some files.

I found 0x8 which is in global variable name at [screen name].bky, and then just delete it(0x08) and re-zip.

delete 0x08 on my bky file -> re-zip -> rename to *.aia -> import aia file to app inventor.

it works and builds well.

If you export and post the corrupt. .aia here for MIT to examine, that would help avoid the problem.

Hi, I have the same problem tonight with an .aia, albeit a different character:

App Inventor is unable to compile this project.
The compiler error output was
java.lang.IllegalStateException: org.xml.sax.SAXParseException; lineNumber: 92; columnNumber: 8560; An invalid XML character (Unicode: 0xb) was found in the element content of the document..

I exported the aia et reimported it, didn't change a thing. I dezippted it and looked for a 0xb somewhere without success.

I made almost no change since the last version which compiled fine. Any idea would be most welcome !
The aia is attached.
MyFoalsMLTest.aia (1.1 MB)

This is a big project, with loads of extensions, developed over a long period of time.

Browsing the blk files in 7zip, I noticed loads of comments.

Removing all of them from every screen using the @kevinkun AI2Helper browser extension, it was able to build on the code server.
MyFoalsMLTest (1).aia (1.0 MB)

Hi ABG, thanks a lot ! I'm not sure I totally understand what you did but I'm very thankful !
It sounds like my aia was corrupted by accumulated comments, is that it ? is there something I could do to keep it clean ?

The browser extension I used:


Also, don't hop on every extension you see.
They don't run on iOS, and they rot over time through neglect.

Watch for other errors at