Problem viewing web page on custom web view

i don't know what i have to enter in ID:

image

without that web page doesn't load
i tryed valure 1 but nothing happens

Hmmm, documentation / images for the latest version have not yet been updated.

If you have just one custom webview, then use a number = 1

If you have more than one custom webview then increment your Id numbers accordingly. Do not try to use the same Id number for different custom webviews.

i have only 1 customwebview and using 1 don't work..

page doesn't load
image

You might need to set the getwebview block, I can't confirm as this extension crashes my companion.

[edit] Having a senior moment or PICNIC

Yes @carto_lover will have to set webview first before using any method.
The flow is like below:

  • Create WebView
  • Set WebView (it makes the given webview active which will then execute the methods)
  • Go To Url

Like so

image

thanks now i can see the web page...

but i cannot do select image...
but navigating if i open that popup i cannot tap on scegli file!

do i have to enable something else for JS?

This should work:


tryed this.. with no success

@carto_lover you should check this once again:

You can set properties and run methods only after creating a webview and making it active.
The designer properties are exception and can be changed anytime.
Try this:

You can get FileTools from here:
http://sunnythedeveloper.epizy.com/2019/09/27/filetools-some-tools-to-work-with-files/

i tryed to reproduce on my project because you project cannot be imported on appinventor. maybe bacause you use something like kodular or thunkable and are newer!

now i can see the files but also if i choice one of them seems not has been selected!

There was a small mistake in my blocks.

Thanks That fixed!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.