Build failed! [RunAapt] ERROR: Error running AAPT

can anyone help me with my project, i cannot build my project. i dont rlly know whats happening with my project, is it because my project is 25 mb in size?


It shouldn't, since the limit is above...what error do you get? Do you want to share your aia file?

here is the link to download the aia file, since i cant upload it directly because of the size limit

What error do you get when you try to build. Show the entire error.


I was able to build on the code server after
deleting one of the two Jasper files.

The trick was to sort the assets folder of the .aia file by name in 7zip, to bring together the almost-duplicates.

1 Like

it worked, thank you so much for giving me a solution for this problem on my project!

Already exist in FAQ


I failed to benefit from your prior post because my idea of 'the same' was too tight.

I also did not have the idea of doing a name sort of the assets in 7zip to highlight the similarity.

So I expanded the text of your entry in the FAQ, and left my entry after it to catch the people who didn't think to sort the asset file names.

You still get credit as the first to find the problem.

It can be difficult to spot duplicate file If you have to many assets.

Since I have helped lots of users with varying issues I've got a habit to extract files and by doing so you get a prompt to override the file or not.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.