The Application MIT AI2 Companion has stopped unexpectedly

Friday we had no issues with the Emulator running and Monday when we returned to school it is now giving us this error when we try to connect to the emulator.

I am wondering if a port was blocked on our network at school causing this issue.

I have uninstalled the software and reinstalled it MIT_App_Inventor_Tools_2.3.0_win_setup and still having the same issues.

Any help would be appreciative that I can direct to our IT department.

Thank you,
Mr. Hunt

Welcome Phillip

School IT departments have a difficult job protecting a class' Web safety. Sometimes they block critical things. Sharing this School IT/Network Admins: Information specific to school networks with them might help.

See these links regarding other classes that had and solved emulator issues similar to what you describe by unblocking ports and whitelisting certain url's.

Kindle Fire 8 not connecting to computer

Perhaps one of other's classroom issues is discussed and solved in the above discussions. Is anything there familiar?

Share the information. You should, with the help of your IT people solve this. If not, let us know what you tried?