Error Code 4003 & 404 in Navigation function

So I was trying to do a GPS app, but then when I pressed my navigate button, it showed an error code 4003, then like a 404 something, can anyone help?

what about doing a search in the community?
https://community.appinventor.mit.edu/search?q=4003%20order%3Alatest
Taifun

Hey Matthew_Xie

It sounds like you're encountering errors in your GPS app on MIT App Inventor. Error code 4003 typically indicates a problem with the GPS signal or location services. Error 404 usually means the server or resource you're trying to access is not found.

Here's a detailed solution:

  1. Check your device's location settings to ensure GPS is enabled.
  2. Verify that your app has the necessary permissions to access location services.
  3. Ensure that your app's components (like the GPS sensor) are correctly configured and initialized.
  4. Test your app in different environments to see if the issue persists.
  5. If using a web service for navigation, ensure the URLs are correct and the server is accessible.

Using these steps should help resolve the errors you're encountering.

You can also visit to this https://community.appinventor.mit.edu/t/error-4003-403-in-map-app/53591/msbi

Thanks
(Marcos)

I've identified the problem and submitted a fix for review on our end. In the meantime, you can sideload an updated version of the companion for Android or join Apple TestFlight for the latest beta version.

Android Companion (2.70d1u): Dropbox - MITAI2Companion-270d1u.apk - Simplify your life

iOS Companion (TestFlight 2.64.6 build 6): Join the MIT App Inventor beta - TestFlight - Apple

1 Like

Sorry. working now

I entered the correct starting point and destination (latitude and longitude), but it shows Error 404.

Welcome @erichou

Are you using Companion 2.70d1u ? There is a bug with ors. See ewpatton's comment above. Until the bug is fixed the only way you can use ors is using that temporary Companion in live development.

AYUDA

Please do not use caps lock, that is considered rude in our community.

Hey, i have a restricted student account, and i tried the android companion patch on my school account and my teachers home account. Do you think you can provide a more accesible patch?

That was for ewpatton

the 403 error is 'fixed' in the test server.

That might work for you.as long as you are only testing the 'fix' which will be posted in a few weeks or less on the main server.

Thank you, i will get back to you tomorrow to see if the server works.

Hey, i just exported and imported my app onto the test server, and am trying to get the companion to work. I think the problem is the restrictions on my phone, and i will post a success or failure of the app tomorrow.

Hey, an unrestricted phone wont open the patch, and im not sure i can.

The test server using Companion .70t1u works fine with Navigate using several projects with my ORS code blocks. Make sure you secure the free api token to use the ORS api.

The 'patch' works with Navigate too. :cry: I am sorry, I have no idea why you cannot download, however you should be able to use the test server if your school IT department 'white lists' the test server url .

I don't know when MIT will post the latest version of the code to use Navigate on the main server. You may have to wait until then to successfully use Navigate.

I can download, but the parental controls for my phone say to hand the phone over so we can change the setting. Do you have any idea whag that setting my be?

I do not really know. Perhaps someone has limited your phone usage with an app or How to Use the Parental Controls on a Smartphone - Consumer Reports

If you are a minor, ask your parents possibly if they have set restrictions on your phone and to white list the app inventor related url's?