Navigation module doesn't seem to be working for the last few days

I have an app that was working fine till a few days ago but not fails with 404 error.

I have created a sample app to test the simple map scenario with fixed coordinates and can reproduce the error in that:

The same coordinates work fine when I use python to work with OpenRouteService:

Has there been a recent change to the components interfacing with OpenRouteService?

MIT says they have not made changes.

ORS connections are dependent upon donated servers and they appear to have been unreliable lately See Error 404 when trying to create a route - #3 by SteveJG

I checked ORS using the Navigate control and get the same 404 error using your coordinates in the African desert. I tried ORS using their api and a Web component. Doing this, the route works. :slightly_smiling_face: making using api calls.

I speculate that this issue occurs when using the navigate control might be an intermittent problem due to server overload or other issues by ORS servers.The api may use different servers. Try again in a few days.

Thanks Steve. Interesting that ORS works from non MITApp routes; you tried the web component and I tried python. Also, when using the MITApp route, my quota count on ORS is decremented which makes me guess that ORS did serve the request but somehow MITAppInventor didn't route the response back to the app.

1 Like

MIT has figured out a temporary fix described here

The fix actually works for most coordinates. :slightly_smiling_face: however it does not appear to work using your two locations in the desert. Try again with different coordinates. :cry: Does this work for you?

Not yet. Looks like the fix is submitted on the ucr branch: Address 404 error due to change in Navigation URL structure ยท mit-cml/appinventor-sources@9cd51d0 ยท GitHub

I suppose it needs to be integrated to master before its effect is seen?


The use of Companion 2.70d1u is a temporary way to fix the issue. It works well.

Have you loaded the Companion 2.70d1? If you are not using it, ORS will not work. Even using the temporary Companion, some coordinates (such as to connect two locations in the Somalia desert ) Using those coordinates however doesn't work for a different reason. Users of ORS with coordinates not near a larger road elicit the 404 error too. :cry: Probably because the ORS map tiles lack the information to complete a route.

Using the coordinates you are using (the Somalia Desert example) gets a 404 error; however using towns in the same area (Oodwene to Garoowe example) works as other areas in the world.

It may be a few days or weeks until MIT fixes the 404 issue for most users with a new Companion for general use. The new Companion will NOT help users trying to plan a route where the problem is the tiles on ORS servers not containing the required information to construct a route between location. < possibly your issue?

I face the same problem and I tried loading the Companion 2.70d1 but unfortunately it is not working, the same error is still showing - Error 4003: Routing service failed with status 404 Not found-

Welcome @S_A7
Show us the Blocks you used. The 2.70d1 companion does work except when no route is available between the two points. What two points are you trying to establish a route for?

Thanks for responding..
The two points I am trying to establish a route for are the user's current location and a point I had already specified ( it is inside a park which you can't drive in)

Is there a possibility that the route to the second point can't be detected?

Certainly.probable. Try a second point on a city street and see what happens,

Are you requesting walking directions? By default the component defaults to driving.

I don't think so

I stand corrected.

The fix works on the companion but after converting the app to .apk the error is still there.

The temporary Companion only works in live development as you mention. To build an apk users have to wait until MIT fixes the issue for an apk.

Hi Steve, MIT App complains about version mismatch with this apk. Does the companion needs rebuilding?



The temporary Companion only works in live development . To build an apk users have to wait until MIT fixes the issue for an apk.

For Navigate to work again from the main server, users have to wait for MIT to release nb197 and provide a new Companion (2.71 perhaps).
MIT has a fix that works that will be released with nb197 . It is available on it's test server but you don't want to build an apk using the test server.

A month ago I speculated the Navigate 404 error would be fixed within several weeks. I was wrong. MIT is waiting for fixes to other App Inventor issues and features before releasing it. When will the fixed version be available to general users? When MIT is ready. :cry: I have no idea when.

In the mean time, users can test their apps with the test server or the temporary apk. Yes, it works fine.

Thanks for the useful info as always Steve.

Any way to run this standalone on the phone? I am working with a group of kids who want to demo their app at an event?


  • Make a copy of the kids app.

  • load this version of the aia to the test server

  • make sure you use Companion 2.70t1u as shown on the test server splash screen.

  • build the apk using the test server

  • load the apk to the phone using the resulting QR code

  • the app should run on the phone :wink: I tried this using the test server and it works.

Try it. Good luck.

Thanks Steve. Was not aware of the test environment. Will test it out shortly