OSM Routing problem. IT is not worked after built

Navigation does not returned at all.
It is possible to run with old version companion.
But after built, it is not worked at all.

Please help me.

It is not OSR problem. but is a bug on Navigation component.
Thanks for your help.

I tested it, companion is OK. but it is old version. I need recent version of companion.
Furthermore, if I built .apk, this route fuction is not working at all.


1 Like

Maybe this:

Yes. I agree your words.
How can we check when the fixes will be available?
Is it possible to schedule a fix or contact the developer?


You will probably need to wait until the next release.

1 Like

Then, If I change to GoogleMap from OSM, it will be OK?

Use the Google Map api and Google Directions api and you should get correct directions now. Google Map directions is much better than Navigate, more stable and efficient. :wink:

MIT posted a fix on the test server yesterday.
" the test server at https://ai2-test.appinventor.mit.edu has been updated. We will be updating the server with additional features and bug fixes over the coming weeks. So far, the current change set includes:

  • Features
    • New user interface available for testing. Go to Settings > User Interface Settings > Neo to try it out
    • ChatBot component adds a new block, ConverseWithImage to ask questions about images (API key needs payment for gpt-4)
    • Palette categories can be independently expanded/collapsed
  • Bug fixes
    • Fix a 404 error in the Navigation component
  • Internals
    • Fix an issue with running d8 on Windows machines

Since this will be a component release, you will need to install the test server companion when using new component features." Supposedly this will allow compiling an apk. I haven't tried it yet. If you do use the test server, realize you should not post the apk to GooglePlay for numerous reasons. Wait to post to GP until after the feature is available on the main server in a few weeks so avoid updating issues.

Oh great news.

Can I get a google maps example? It would be nice to have an example where you input the departure address, transit address, and destination address, display the route, and express the distance and time.

Millions Thanks and Regards

or Google Static Map

I meant that app inventor block example. I tried google map several times but failed to draw google map. So if google map using app inventor .aia is available, let me know.

Thanks in advance.

App Inventor does not have a component to manipulate Google Maps. The api is manipulated by making url calls.

See Maptype not working with Map component (and an alternative using Google Static Map) - #7 by SteveJG

A fix for the issues affecting the Navigation component is now available on our test server at ai2-test.appinventor.mit.edu.


Is it available on official page : ai2.appinventor.mit.edu ?