Blocks are missing

Hello.
When opening the program in Screen1, 99% of the blocks are missing. At the top of the window, the message "Blocks workspace did not load properly. Changes to blocks for 6637423262302208_Screen1 will not be saved" appears.
I have shipped intermediate versions, but they are loaded with this message too.
What is the problem?

We did a release earlier today. It's possible there is an unresolved issue. Can you export a project and share it here with us to test?

CLIENT_DS18B20_v1_18.aia (214.5 KB)

I'm not seeing any error when I import that project into App Inventor. Can you let us know what browser and operating system you're using in case the error is platform specific?

Edit: Never mind. The issue is due to a new block variation we added. The format of the block text changed and we only updated the English string only. This is resulting in projects containing the block in question to fail to load in other languages. I have prepared a fix that's being reviewed. As a temporary workaround you can switch App Inventor into English until we deploy the fix.

(added to FAQ)

Yes you are right! After switching App Inventor to English, everything was fixed.
I use:
Windows 7
Google Chrome (Version 85.0.4183.83 (Official assembly), (64 bit))

Try loading your project on http://ai2-test.appinventor.mit.edu and see if it loads correctly there. We've deployed the fix and would like to confirm it is working.

Hi Evan

I thought nb185 was released, withdrawn temporarily, released again - is that incorrect?

We have a User whose Projects are in Russian and the Blocks fail to load correctly. He/She can load the Project without issue if using English:

We don't ever withdraw releases due to the nature of how the App Inventor code base is structured. nb185 is out and available to all. http://ai2-test.appinventor.mit.edu/ is nb185 plus one additional patch that should fix the issue of loading projects in non-English languages. We're planning to push the version of the code currently on ai2-test to ai2 within a few hours. Anyone encountering issues loading projects on ai2 should try to load those projects into ai2-test to help verify that the issue is resolved.

korean (한국어) was also occured same error(bug?) in nb185. and nothing problem in nb185a(aka ai2-test)! thank you! hope it available in ai2 soon.

We have released nb185a which fixes this problem.

2 Likes

Yes, everything works!
If there are problems I will write.
Thank.

http://ai2-test.appinventor.mit.edu - works too.