aiStarter update MIT AI2 Companion2 to 2.58au

1.Download http://ai2.appinventor.mit.edu/companions/Emulator.apk to the installation directory of aiStarter \ commands-for-appinventor, for example: C: \ Program Files (x86) \ AppInventor \ commands-for-appinventor.


2.run aiStarter and open http://127.0.0.1:8004/start/

3.cmd:
cd C:\Program Files (x86)\AppInventor\commands-for-appinventor
adb devices
adb uninstall edu.mit.appinventor.aicompanion3
adb install Emulator.apk
adb shell rm /data/local/tmp/Emulator.apk

2 Likes

I’m looking for who would benefit from this procedure, compared to suffering through the Companion’s self-update sequence.

Perhaps a school administrator, who doesn’t want to expose students to the Companion update dance?

self-update : Error upgrading from 2.11 to 2.58au.

(added to FAQ)