Your build failed due an error in the DX stage, not because of an error in your program

ciao, ho letto tutti i possibili motivi elencati, il problema si verifica solo abilitando quei gruppi di blocchi,
sono tutte azioni semplici, una serie di bottoni che impostano e salvano dati e risultati impostati dall'utente, 36 righe, 36 bottoni.
ieri sono riuscito a compilare , abilitando 4 bottoni, oggi compila solo se disabilito tutti i 36 bottoni

Your description of the app behavior points to probable timing issues.

Try using the code server.

:cry: but there are a lot of them. Either your Android cpu or you router possibly can not keep up.

Ciao @Dario_Lazzarin,
extending @SteveJG suggestion, and thinking about the (pretty weird) fact that yesterday you were able to compile and today not at all, have you tried to clear your browser's cache ?
BTW, the code server is:

intanto un Grazie a tutti quelli che cercano di aiutarmi.......grazie
ho provato con il server del codice ....risultato stesso errore di DX,
Lavoro con un notebook con INTEL i7 11°serie, 8 G di ram..
ho provato ad disabilitare tutti i blocchi escluso i 36 gruppi incriminati, ed la compilazione è riuscita,
quindi in teoria non dovrebbero esserci errori .Il file aia è di soli 1,8 mb per cui non è troppo grande.
domanda il tinydb , che nel progetto viene usato spesso, 12 cartelle diverse, potrebbe influire?

You have two warnings Dario:


Also, what Browser are you using?

That would probably be better served by a List View Component.
Are you using 36 Button Click events?


yes 36 Button Click events

i 2 avvisi gialli sono blocchi sciolti

AX32_semplice.aia (1.8 MB)


This project has massive violations of the Don't Repeat Yourself rule.


  • tables
  • procedures and parameters
  • generic (any) blocks
  • data storage and access

per esempio quali?


Post#22, Cocktails4.aia

ciao Cris
conosco quell' app. E' un app basica ed lo sketch di arduino anche.
pl mio progetto è per un uso professionale.
comunque il mproblema è che non riesco a compilarlo. e credo di aver capito che il numero degli elementi usati sono troppi.

Hi @Dario_Lazzarin,
I've tried to compile your aia on my PC, and neither I am able to get it compiled. It takes a certain amount of seconds to load (!), and when your blocks are on my screen, the PC (DELL i5 with 8 GB RAM) slows downs dramatically.
I' ve tried to disable blocks here and there, but no success. The two warnings, though eliminated, are irrelevant.
Sorry, I have no other ideas for the time being. Probably too many images ?
Ciao, ugo

That doesn't matter - what matters is how the Blocks are used. That project demonstrates a better way - and it compiles.

ciao Ugo grazie

May I ask if this app ever worked as it should, as it is slow to start with companion plus it gives a lot of error messages.

Now to the bugs.
Procedures runs in wrong order e.g. you run the totali-procedure before filling in values for calculation.

I found this in three of your procedures, component et_ingr36 shouldn't be in this list but et_live36 should

I even found these mismatching blocks as it gave me errors when I did something, as et_ck11-16_fatti requires int and not string.


If it suits you, you may try this modified aia with lesser blocks (-5000) then yours..

AX32_semplice1.aia (1.6 MB)

P.S. You would need this file as well if you are going to add/remove but keep in mind to match the rows.

1 Like

Hi everybody, @Dario_Lazzarin I will let you know my experience and how I faced this trouble at least 10 times with a very huge app.
The size of my .aia is around 1.5 MB and the .apk is around 6MB, it has 8300 blocks by now, but it had around 12.000 in the past, now also has six extension, only one screen with around 250 arrangements (maybe 20 like full screens an the others inside).
The issue came in my case always by the same 3 causes:
1- Puting very bigs blocks in the backpack.
2- Bring blocks from other projects or checkpoints.In particular if ther is a grouping of component with the same name. I mean, not tiny blocks of components that exists several times in the code, just I mean components like Procedures or Button clicks, etc.. (all that you cannot repeat).
3- Excesive copy/paste to create a very big block.

So, how I solved it?
Always, the 100% of the times, REDUCTING DRASTICALLY the quantity of blocks with "any components" metodology (also "make general" option in the menu").
If I reduce around 200 blocks my app compiles again. When I looked your captures I saw a great oportunity to do that, you have too much "Boilerplate code" and I am sure you abuse of ctrl C / ctrl V, like me.

I have analized my .aia in a lot of ways and the explanation I found is that the code compiles when the afected blocks that cause the erros at DX stage changes their blockId= in the Screen1.bky file in the .aia.
I had a moment when disabling a label.text in the code it compiled OK, and enabling again got DX Stage error, after that only it compiles again when this label appears with another blockId= in the Screen1.bky.
I hope it help you and the same for all.
It would be nice that people from MIT AI2 project show the logs of DX when it fails and when te same code compiles OK.
Good Luck !

1 Like