Trying to use a different emulator for App Inventor

I currently don't have access to a phone right now and I'm struggling with the default emulator that runs with aiStarter. I'm trying to connect a new emulator with app inventor; I attempted connecting with the AI companion in BlueStacks, Memu, and Android Studio but all of them came up with an error after getting to 15%. I tried making my computer recognize an android studio avd as a USB device so that i could connect that way but that didn't work either. I've been stuck at this for a while, any tips would help.

What is the error message? :thinking:

You might have done it successfully, but I have made a guide. See here -

This happens with every emulator I try.

This happens when the device and App Inventor loose internet connection.
But I have never faced this on an emulator.
It happens only if your computer went to sleep.

Are you sure all your emulator settings are default?

Im pretty sure they are

Try creating a new device.

I found a solution for this, I checked "Enable Android Debug Bridge (ADB)" under Preferences in the settings on BlueStacks and when pressing Connect > Emulator on App Inventor while aiStarter is running, it just opens and connects to BlueStacks rather than opening the built-in emulator. I didn't think the solution would be that simple but that's how it worked for me.

1 Like

Using the emulator's copy of adb.exe also helps with GenyMotion.