Trying to connect LG Stylo with Firefox (no QR code to scan with companion app

Try using Chrome

Thank you for the suggestion, however this is the result. Anything else I can try? I am stuck building and installing to test apps. I really appreciate your help!


Have you seen FAQ Section: Companion and Emulator ?

Hi @Geneva_Tungate,

The QR code just stores the 6 characters (in bold) as an image for the convenience of scanning. You always have the option of typing those 6 characters in rather than scanning the (absent) QR code.

You mention that you're using Firefox. Can you tell us what version of Firefox as well as what operating system you're using (Windows 10, macOS 10.15, etc.)? If you have any browser extensions installed, please let us know those as well so we can try to understand why they would block the QR code.


Firefox 80.0, Windows 10, LG Stylo (Cricket) .. Brand new install. Also occurs with Chrome although placeholders appear. I am aware of the Alphanumeric code a QR code generates, however The LG Stylo does not allow entry of the code unless I add a carriage return then responds with an error. I also installed Chrome (newest version). Been trying for the past month. I am so frustrated. I really appreciate any help I can get. Thank you!

What happens if you just type in the code (no return) then press the yellow button (connect with code) ?

Nothing happens

Hmm, what if you plug in your cellphone with a computer using a cable, then you download the project to your laptop then take the project and send it to your cellphone.

That's what I've been doing. My goal is to simultaneously view the app while coding. Makes for easier debugging. Thank you though.

I think you are opening a page other than Mit App Inventor.
Try to delete all the pages and then you open the page for mit app inventor only

Do you mean tabs in firefox? I apologize but I really don't understand "pages". TIA


tabs In Chrome

I am confused with you, Tab or page is the same

I tried Chrome with just the MIT app inventor tab. See second post for screenshot, I'll try again tho.


Oh, you have to download Chrome on your PC.
I'm sure your problem can be solved if you use chrome

i have to have chrome on both my android phone and laptop? Because it is a new install on laptop

The issue is with your laptop.

Try running the App Inventor site in incognito/private mode (CTRL+SHFT +N), this should run things without any fluff or extensions you may have installed.

you means you have installed chrome

Yes I am currently trying to use Genymotion emulator