SharingTools Extension [Free & Open Source]

When set up as you advised your extension DOES generate the required multiple attachments.

However, none of the apps on my phone that I listed actually deliver the attachments. For example, on the email app I get the message "Unable to attach file". The other apps don't give an error message.

WhatsApp works OK.

The SharingTools.ShareFile works OK in email with a single file.

1 Like

Okay i got it, for the SendMultipleFile function it can only send lots of files well on whatsapp and still not working properly in other apps, that's because there are probably two factors,
the first factor is because other apps still can't accept multiple files
and the second factor is because the code for sending multiple files to another app is different, but in my opinion the problem is not due to the second factor but the problem is in the first factor, because the code I use is very neutral and special so I'm not sure if my code is wrong. :wink:
And if I have time, I'll update my extensions when I find code that works more perfectly.

Best Regards,
Salman Dev

Hi @Salman_Dev,

What you say is very interesting.

Please don't misunderstand - I was not suggesting any fault within your extension. Whilst WhatsApp is not ideal I'm very glad to have some method for exporting multiple attachments and am sure the problem lies within my phone, its apps or the Android version. That may become clearer from any feedback from other users.

Look forward to any developments you come up with. I'm happy to test if that would assist.

Thanks again for your fast and helpful responses,


1 Like

Thanks a lot :kissing_heart:

Okay, no problem :grin:

maybe :face_with_monocle:

:innocent: :heart_eyes: :+1:

You're welcome :kissing_heart:

can i share multiple images to whatsapp by just one click?

what do you mean about just one click

Okay, I think you should try my extension so you can know how they work

i tried your extension and is is showing this.
and this error in my phone

maybe i am wrong in bock section please can u guide me
can you share your aia file

1 Like

you need to put full path it cant take image from asset


Please take a look at this :

There seems to be issues with the paths → listFilePath:

So there is no path that works with listFilePath.
You should fix that.

Btw, in Kodular only this path (full absolute path) works:

You have already got a topic about this in the Kodular forum. Please only ask in the forum of the builder you are using.

This works on my Samsung S7E Android 8 but the only 3rd party app I have that will deliver multiple files is WhatsApp

Having also tried sharing via native email, Gmail, GoogleDrive, Dropbox they either throw an error message or silently fail to deliver the attachments.

The SharingTools.ShareFile (single item) works OK with these various apps.


I checked it on 4 of my test devices (Android 8, 9, 11). It doesn't work on any of them.
This is definitely a bug with the extension.

One of these two paths should work on all Android versions in any case:


It would also be possible for the extension to use a relative path:


But even in this case it doesn't work.

  1. Have you tried sending multiple files other than just that one?
  2. I see the path that you add is just like this :
    Are you sure your photo is on that path?
    I think your photos should be in a separate folder for example:
  3. I am sure my code is not wrong because the code I use is very secure,
    if you want to see I will show you

yeah it's because the problem that I have explained here :

I doubt the files will be attached. Show a screenshot of it.

And I just want to say that I will keep updating this extension because I also have the latest ideas so I probably will add a new function that is very useful so you don't have to worry about all of my extensions I will keep updating, if i have time. :grin:

Yes, this works with Kodular (with the full path: file:///storage/...)


1 Like

Hmm, but can my extensions work on ai2?
I'm sure it can because before I published this extension I tested it up to 23X on AI2 and the results worked :thinking: