RE: MIT app inventor just stopped working on all projects when any extension added

Hi, you have just moved my post to ClickZ thread

but I think this is incorrect because my post is connected with ANY extension. ClickZ was only used as an example. My problem is connected with MIT app environment as a whole so in ClickZ thread there is low chance of getting help.

Greetings :slight_smile:


Today, as everyday, I wanted to continue my work on my app so I loaded my project, connected MIT app inventor with my phone via USB and then... error :frowning:

Here below is the error after I created fully new blank project, connected via USB, added label (no error), added ClickZ extension (only as example) and error appears:

When I use ANY OTHER extension this error appears again with extension name in red square.

So here are conditions when this error appears:

  • MIT app companion 2.62u and 2.63u version used (didn't checked other)
  • Project is started in emulator or phone via USB
  • Already started project or even completely new blank project
  • ANY extension added to components (after importing = no error, after dropped to project = error)
  • even tried with new mit app inventor account =same situation, error

So everything is OK as long as I use built-in components like button, label and so on.
I tried clearing cache and data files of MIT app companion = no effect

Everything was working fine until today. Nothing changed in my PC or my phone. Even if so, creating new project or reinstalling companion app should help - but it didn't. :frowning:

For me it looks like major MIT app environment bug, but as I read community it looks like this problem is not met by other users so I don't know.

Any ideas how to work this out? :slight_smile:

Okay, I moved it back.

Good luck with your problem!

P.S. You aren't on iOS by any chance, are you?

1 Like

Nope, making app only for Android on

Have you / can you also test with wifi companion on your device? Same outcome ?

What Android version is your device?

You could also share a sample project that crashes...

OK, I don't know what had happened but right now everything is working just fine as it should be. The problem that I described was making me mad for last 10 hours.

Maybe it was caused by the new 2.63 companion version that was rolling today?

Anyway, thank you all guys for help. Appreciate that :slight_smile:

Thread can be closed now.

Probably the version update to AI2 and the companion just needed to catch up with each other :slight_smile:
Pleased to hear the problem is resolved.

1 Like