New Connection problem (using Companion with Chrome and some other browsers)

yesterday all worked well. Today there is a connection problem. See pic. It continues to be present inspite of restarting the PC and the smartphone (Samsung one). The companion is the latest. What to do?

You are not alone. Until MIT discovers what is causing many to have this issue, follow this work around advice MIT App Inventor Issue (using Companion).

This appears to be an issue involving latency in your ISP. Check the Use Legacy check box on your Companion screen before you use the QR Code and Chrome will work without getting stuck at 20%. If you do not check Use Legacy before pressing the QR Code button, you will get stuck.

Did this help?

1 Like

YES, thanks a lot! Very easy! It works. But why by now?

When I try to connect with my phone and via the app and test something it is stuck at 20% and doesn't wanna move. It was alright earlier and I had it once while using kodular but it fixed itself like 20 minutes later, does anybody know why this is happening?

it is a small app
I have a good and stable wifi connection
It worked earlier on bigger apps


  • stops at 20% when connecting to Companion
  • after selecting "Use Legancy Connection" I get an error:



  • works without a problem

Worked for me too :slight_smile:

Looks like Chrome version 89 broke our WebRTC implementation. Looking into it now.


1 Like

(added to FAQ)

And the problem with Chrome 89 has been mitigated. Chrome 89 should work now.

It works for me, thank you.

Works for me in Brave.


1 Like