New Android announcement for the API 14 (level 34)

Before the next end of August the Android Builder must migrate to the Android API 14 (level 34):

1 Like
3 Likes

I think this test server SDK 34 not runs fine.

1 Like

but how

ok i now

Play console mi dice questa cosa, come posso risolvere?
L'app deve avere come target Android 14 (livello API 34) o versioni successive

Dettagli

Per offrire agli utenti un'esperienza sicura e protetta, Google Play richiede che tutte le app soddisfino i requisiti relativi ai livelli API target.

A partire dal giorno 31 ago 2024, se la tua app non avrà un livello API target risalente al massimo a 1 anno prima del rilascio della più recente versione di Android, non potrai aggiornare l'app.

Play console tells me this, how can I solve it?
The app must target Android 14 (API level 34) or later

Details

To provide users with a safe and secure experience, Google Play requires all apps to meet target API level requirements.

Starting August 31, 2024, if your app does not have a target API level dating back at most 1 year before the release of the latest Android version, you will not be able to update the app.

At this moment as a quick solution you might use this CLI tool to change target API level.

Don't panic... today is July 4th...
Every year this is the same procedure...
Currently there is nothing to do... just wait...

The test server already is available to do SDK 34 tests and one day the main server will be updated to target SDK 34, too

Taifun

3 Likes

Hi there,
I meet a new trouble about my application developed with App Inventor 2.
How do you, developers using Google Play Console, treat your applications ?
Basically I want to know if App Inventor 2 keeps to follow the latest version of Android API.
The massage sent from Google Play Console is the followings,

To release updates to your apps, update your target API level by August 31, 2024

SeasonClockSeasonClock

July 4, 2024 23:25

We found that your app targets an older version of Android. To provide a safe and secure experience for our users, Google Play requires that all apps comply with our target API level requirements.

Starting August 31, 2024, apps that do not target an API level within one year of the most recent Android release will no longer be able to be updated.

Show detailsarchive

expand_less

SuzukiS

Don't panic... today is July 4th...
Every year this is the same procedure...
Currently there is nothing to do... just wait...

The test server already is available to do SDK 34 tests and one day the main server will be updated to target SDK 34, too

EDIT: also to only change the target sdk in the manifest as @JEWEL is suggesting will not really help because there are also the behavioral changes for SDK 34 to consider...

Taifun

4 Likes

Hi Taifun,
Every time I wonder you help me thank you.
I am very reliable to hear from you that App Inventor will catch up every Android version up.
SuzukiS

2 Likes

how to fix this problem i need help

Hmm strange, this shouldn't give an error message, at most a warning that this will be mandatory from August 31st.

1 Like

Ignore it (or ask the Google Dev Support).

1 Like

sorry it cant proceed

1 Like

i'll try

1 Like