My Data-Entry Keyboard Once Worked .


I have a data-entry keyboard which worked great when it was on its own screen. The first screenshot shows data before entry into the pressure label and the second screenshot shows the same data after entry into the atmospheric pressure label. The data has cleared off of the screen and appears below the button image you press.

Now, that I have incorporated this as a virtual screen, I can no longer get the data entered into the keyboard to show up in the green "screen" label. Following the block logic, the data still shows up in one of the three labels below but it no longer displays on the green "screen" label. The first block image is that of the functioning screen. The second block image is from the virtual screen.

Might someone throw another pair of eyes on this and help me find my error?

What name have you given the "green label" ? (Is it Display_Screen.Text ?)

The "green label" should be in the virtual screen with the other elements (for simplicity)

It may be easier to put all your number buttons in a list and test for that, instead of them "not being already handled", which may pick up button actions elsewhere on the real screen (in other virtual screens).

I attach a simple example project

setValues.aia (3.4 KB)

Need to see the .aia export to catch Designer problems like green ink on green background.

Yes, that is correct. Here is a view of the Design Page.

This is weird. I have no means of uploading an image or file. All my header choices are missing.

What might I have done to prevent me from seeing my header selections? I have no means of uploading a file or image.

Thank you, I will check out your file. What you say about not inadvertently triggering other events (or vice versa) makes sense. I will explore your sample file this evening.

Oops, I won't be seeing your example. I do not have the means of loading .ala files directly to my phone. Instead, I upload .apk files I build in the App Inventor using the companion app. Is it possible that you could share the .apk, at least the portion with the example you wish for me to see. I am not really skilled enough to see an app in action and reverse engineer it. I have enough trouble with proven designs;).

(Canned Reply: ABG- Export & Upload .aia)
Export your .aia file and upload it here.



Are you on Windows?
You might have the Snipping tool, handy for screen grabs that can be pasted (Ctrl-V) into whatever board post you are currently typing.

OK, this window now has the functions ribbon on top. Here is the .ala:

June_21_BU_B.aia (2.0 MB)

Let's add up the Heights of everything stacked in Virtual_Calculator_4:

The whole Arrangement is 100% of the Screen.

Label34 is empty, and 5%

Here's that Display_Screen Label, with a measly 40 pixel hard wired Height?:
That's two problems.

  • You broke the percentage rule, that everything should be in percents that add up to 100 or less.
  • The Font Size (letter height in pixels) is 48, bigger than the 40 pixels you chose for Height.

I'll pause here for you to finish the height audit.

I ran your app in the Companion on my BlueStacks emulator, to see how responsive the design was.

It fails.

You have to juggle your Heights and Font sizes better.


Oh My Gawd!

If I didn't think I would cause damage to my apartment, I would be pounding my head into the wall right now. Here I am, beating myself up searching for a code violation and it was the most simple of all! I must remember that I can't fit a liter into a quart;). Thank you so much for that observation and review of the branching structure.


I do have another question to ask of you. Because my system is designed to connect to a remote device (only on request) I get a runtime error when I actually run the app because it is looking for BLE components before their time. When the BLE connection was on its own screen, this didn't happen, if only because the user would press the start button shortly after the screen opened.

I have tried hiding the BLE components in the button press for the ATMO device but the runtime error screen still shows when I open the virtual BLE screen. Mind you, the error is a red herring, as it invites me to close the program but pressing outside of it makes it go away and the app runs as it should from there on out.

So, my question is, how would you handle the false-flag runtime error associated with the virtual BLE screen not being opened at the start?

Thank you for any light you can shed on this and again, thank you for your cogent observation about my tring to display too large a font in a label.

That sounds like something in Screen1.Initialize that should not be there.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.