Is there a way to change the screen brightness?

hello!, im making an app where i change my screen brightness, but its not working, i used an extention where i could control that, but it says i need to enable Write_System..

Try this

it says the permission has been denied, please enable at settings

Test it as apk and see if it works

i tried and i got the same error message

See also this

Well, i tried everything and still aint working :frowning:
thanks for your help ill look at it again see if i can find anything

1 Like

Which Android version are you using for your tests?
The paid version of my settings extension is able to set the brightness ... there also is a test project available...


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by icon24 Taifun.

version 8.1.0

hey, could someone help? im still stuck :sweat_smile:

does the test project work for you?

nope, it doesnt for some reason

to be able to set the brightness, you first have to set the Brightness Mode to manual


also first you have to allow to modify the system settings...


i cant find that screen, whenever i open modify sistem settings, mit app inventor aint there

the name of my test app is settings and the device settings screen will be opened during Screen Initialize...
you might want to post a screenshot of what you are getting after opening the test app...

Follow the opt-in URL to get access to the settings app and to be able to download it to your device


your test app did work on my device, but when i open the modify system settings on my device to try to enable on my apk, its not there for me

ok, so the extension is working fine

well, your app without the settings extension obviously does not work...
why do you think, I spent time to create the extension if we could have the result without it?


i have been using another extention, a free one that i found here on mit, but sadly it wont work

Did you try this extension which changes the brightness of the current window only....

hmmm, just tested not working for me here...perhaps needs to be compiled?