Failing to Connect BLE

This is my first time posting. I have spent 2 days pouring over trying to resolve this issue and finally decided to reach out for help.

I have a BLE OBD2 scanner I am trying to connect to with my MIT App Inventor app but I am unsuccessful. I seem to get no response and will eventually get a connection time out no matter which connection method I try. I created a pick list so I could try to see if I could connect to other possible services using the .ConnectToDeviceWithServiceAndName. method without compiling code every time.
Those other methods were also unsuccessful. Entire .aia file is also attached.

I am able to connect to my ESP32-C3 using the .ConnectWithAddress code but the same code is not working for the BLE scanner. Please ignore everything after BluetoothLE1.Connected as that portion is not yet developed. I got stuck when I couldn't establish a connection.

Using a BLE_Scanner app from the play store I am able to connect and bond to the OBD2 scanner so the issue seems to be my connection method. I attached my code as well as a screen shot of the results from the BLE_Scanner app with the OBD2 services/characteristic.

Thanks in advance for any help.

BLE_ODB2_Scanner.aia (201.6 KB)

Try this one to connect to your scanner (it says micro:bit in the header, but that is not important.
BTstarter20240306.aia (197.4 KB)
If that works, go from there. If not, explain what went wrong.

I tried this app and it could see the device but was unable to connect. This is very similar to my experience with my app.

I do not know. Maybe someone else has an idea @Anke ?

What is the make and model of your OBD2 device?

Most of the posts here for OBDII devices run on pre-BLE Bluetooth, like the ELM327.

It's a Chinese brand by Shenzhen Donghai Chuang Technology Co.
If I was unable to connect via other play store BLE scanning apps then I would have attributed the issue to the device.


Yes, most posts use pre-BLE bluetooth using the bluetooth serial implementation. The ESP32-C3 chip doesn't support non BLE bluetooth. If I can't figure out the BLE I may need to switch to a WiFi implementation solution.

Thank you

I had the same result with BLE_permListDevConnect_allAndroid.apk

I am able to see the device. I try to connect, it says connecting then after maybe 60 seconds went to connected: false.

Thank you

Hmm, the same result with the other APK?

Should something have changed with Android 14? Unfortunately, I don't currently have an Android 14 test device. Maybe someone else with a Android 14 device can confirm this.

No, it works fine also on Android 14+

Dear @Colin_Marker,
this device (V1.5) is quite an old one, it uses the ELM327 and I'm almost sure (95% :smirk:) that features a "standard" BT and not a BLE.
In my post that @ABG has linked you'll find a lot of stuff related to the use of a similar device.
Give it a look.

EDIT to be sure that the OBD device is working fine and can successfully connect your phone, you can download a ready made app like TORQUE lite (free) and see what happens..