Facing issue with AI companion connection

Well, I thought, new software released, help files not updated. Can you provide a link from where to download the current software: D? I think usb connection will be better than wifi.

Maybe I'll do a short video tutorial on this later ...

Yes, I generally prefer USB connection for Companion, as it is more stable and significantly faster.


It is not working for me. The app is freaking out same way it does if I use legacy connection on the AI companion.

This could be unrelated....before connecting to companion, remove any blocks from Screen1.Initialise (or stop anything that starts when the app starts), and try to connect again. Do you still get the "freaking out" ?

I have no blocks doing anything as soon as the screen is initialized. Its a static screen unless interacted with. The buttons just start freaking out and flickering, along with the entire screen contents

How long would it take for the AI2 companion connection to go back to the way it was? It is taking a really long time for me to have to build the APK everytime I wish to test the app in a stable manner.

Using Companion with the Legacy Block ticked works presently for most developers. So does the emulator. Sorry these temporary solutions apparently do not for you.

Your issue not being able to get your Project to load for live development is probably related to your Blocks. We can't tell since you haven't shared your Blocks for anyone to test.

As long as it takes to purchase, install and set up (configure) the new servers. Perhaps a week perhaps two weeks perhaps two hours.

In the mean time, you could try a third part offline version of App Inventor or move to Thunkable.

Very sad. Have you ever used the professional Android Studio? Consider Builds with AS are no where as fast as they are with App Inventor. Be patient and glad, this excellent tool will run without Legacy connection soon.

It almost seems like I'm the only one with the USB connection working. :wink:

For me it works

  • on 2 different notebooks,
  • on 3 different PCs
  • with Win7 / Win10
  • with 15 different test devices (Android 4.x, 5.x, 7, 8.x, 9, 10, 11)

and that for many years; actually since my first days with App Inventor.

USB - video

So where could the problem be? :man_shrugging: :upside_down_face:

For me, "Use Legacy Connection" doesn't work with extensions.

1 Like

I am running on MacOS. I tried both safari and chrome. Both gave the same glitchy issue.
Anyways, I've mostly finished up testing via the APK method. Took a couple days longer, but atleast it works now.

I've no problems with that. I opened a big app with 4 (big) extensions and connected to Companion (via Legacy mode): works fine.

Note: I also checked this by previously deleting the AppInventor folder from the test device.

I have no idea why this all should only work for me. :upside_down_face: :man_shrugging:

I checked this also on my Mac Mini with

  • iPhone 6s and
  • iPad Pro (12.9, 4th gen) with the current iOS version
  • Galaxy Note8 (Android 9) (using ā†’ Legacy mode)
  • Pixel 2XL (Android 11).

No issues at all.

I have no idea either. Stops at 50% uploading jar file from extension. After a long wait, it crashes. I'm using Chrome, I will test with firefox.

MIT installed a new server cluster. The server cluster is still unstable. They expect it to normalize by the end of this week so some users may still experience Companion connection issues throughout the week. Most users will be able to Connect by using Companion with the Use Legacy Connection option ticked before attempting to connect.

1 Like

This issue now seems to be fixed.
I just tested it successfully (without legacy mode).
Thank you @jis.


Just tested and works fine without legace mode :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.