aiStarter in Linux Fedora

Hi, I am a student in mobile app development. I am using a linux fedora system and I am having more than a few issues with getting aiStarter to work on my system. I am sure it is more me than the software but I need to be sure. I downloaded the appropriate (non ubuntu) package and extracted it to /usr/google/appinventor every time I try to run the aiStarter program it gives me an error and closes out. What have I done/am I doing wrong. Please be gentle... I am a noob at this but not totally wet behind the ears.

  1. Just extracted or installed ?

  2. Why the aiStarter ?

I run linux, and use Genymotion for an emulator - faster,easier,more up to date Android - what is not to like :wink:

or do you want to connect by USB ?

1 Like
1 Like

Hi, just extracted it, I couldn't find any fedora-based information on how to install it and to answer your second question they are using aiStarter on the course so it is mainly so that I can follow along before we graduate into android studio.

If there is any documentation and if anyone knows where it is as to how to install appinventor on Fedora I would appreciate it because I searched but didn't find it.

Oh and I am trying to start an emulator but even when I tried to use my device it told me aiStarted was not running.

Hmmm, have just downloaded the "other" linux tar, and there does not appear to be an installable packed, just files.

My guess is you just have to create the
directory, and then copy across all the files in
directory ?

This will probably leave the executable files isolated and possibly without executable flags, but you can then try running
and see what happens ?

1 Like

I'll give it a try and let you know what happens

1 Like

I tried as much as I know how to do... I am not sure what I am doing wrong if anything.

Hi sorry I have no idea what that is, it looks promising though. Do I need wine / bottles to run it?

Sorry I just read the article properly, I was in a hurry previously thank you I will try this.


I tried companion and it worked on my device so I will use that way instead as I am falling behind with the course by trying and failing. thank you so much for your input. I appreciate it.

1 Like

Fine, so if your problem is solved, click Solution on the best answer so others can learn from it too.

Check that the executable bit is set:


~$ chmod +x /usr/google/appinventor/commands-for-Appinventor/aiStarter

and then run the command:

~$ /usr/google/appinventor/commands-for-Appinventor/aiStarter

Bottle server starting up (using WSGIRefServer())...
Listening on
Hit Ctrl-C to quit.

Did you really answer your question yourself? :upside_down_face:
What should others learn from this?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.