Facing issue with AI companion connection

I can't find a reason why this doesn't work. The help file is very general and doesn't describe where it doesn't work. In the help, I only found a mention that the phone cannot appear in the system as a disk. In my win10, in "my computer", the phone appears as Galaxy S8 with a phone icon. I don't know if this is correct. Drivers for the phone: "SAMSUNG Android ADB Interface" v

I have had exactly the same problem for a few days. The connection stops at 20%.
Everything had been working well so far....

1 Like

I am Also Facing The Same Problem!
My App Version Is 2.60

1 Like

I really don't understand where the problem is.

So again:

How can I find a version in the EXE file properties I do not see the version number. My Aistarter is from the package to which the link I found in the help files and I wrote about.

Download AI2Starter (I use the "Portable" version: .zip), unzip it in a folder of your choice and start it. That's all.

I've been doing it for more than 7 years with all AI2 versions (online / offline) and with almost all Android versions (4.x - 11) and on dozens of devices. I've never had any problems with it, either with Win7 or Win10.

On this page:

There is this link:

You write about AI2Starter. Mine is AiStarter, maybe it's an old program.

Well, I thought, new software released, help files not updated. Can you provide a link from where to download the current software: D? I think usb connection will be better than wifi.

Maybe I'll do a short video tutorial on this later ...

Yes, I generally prefer USB connection for Companion, as it is more stable and significantly faster.


It is not working for me. The app is freaking out same way it does if I use legacy connection on the AI companion.

This could be unrelated....before connecting to companion, remove any blocks from Screen1.Initialise (or stop anything that starts when the app starts), and try to connect again. Do you still get the "freaking out" ?

I have no blocks doing anything as soon as the screen is initialized. Its a static screen unless interacted with. The buttons just start freaking out and flickering, along with the entire screen contents

How long would it take for the AI2 companion connection to go back to the way it was? It is taking a really long time for me to have to build the APK everytime I wish to test the app in a stable manner.

Using Companion with the Legacy Block ticked works presently for most developers. So does the emulator. Sorry these temporary solutions apparently do not for you.

Your issue not being able to get your Project to load for live development is probably related to your Blocks. We can't tell since you haven't shared your Blocks for anyone to test.

As long as it takes to purchase, install and set up (configure) the new servers. Perhaps a week perhaps two weeks perhaps two hours.

In the mean time, you could try a third part offline version of App Inventor or move to Thunkable.

Very sad. Have you ever used the professional Android Studio? Consider Builds with AS are no where as fast as they are with App Inventor. Be patient and glad, this excellent tool will run without Legacy connection soon.

It almost seems like I'm the only one with the USB connection working. :wink:

For me it works

  • on 2 different notebooks,
  • on 3 different PCs
  • with Win7 / Win10
  • with 15 different test devices (Android 4.x, 5.x, 7, 8.x, 9, 10, 11)

and that for many years; actually since my first days with App Inventor.

USB - video

So where could the problem be? :man_shrugging: :upside_down_face:

For me, "Use Legacy Connection" doesn't work with extensions.

1 Like

I am running on MacOS. I tried both safari and chrome. Both gave the same glitchy issue.
Anyways, I've mostly finished up testing via the APK method. Took a couple days longer, but atleast it works now.