Emulator will not work

I am a college student, and I need some assistance. My professor isn't helping me. I can not get it to update or work. I've been downloading and deleting and redownloading this several times and nothing is working and like I said my professor is no help. I have an assignment due tomorrow and I need help desperately.

The emulator is a debugging tool, and does not manifest itself until you try to invoke it from a project.
Did you start a project yet?

Hello Alora. Welcome.

Did you follow the advice here> Installing and Running the Emulator ? Did you follow every step including re-booting your computer?

You have to install aiStarter as Administrator, if you did not, that is the probable issue.

Do you ever find these screens when you attempt to update ?


Please tell us what you tried to do; step by step and we might be able to help you.

I did all of that and it still doesn’t connect. And i turned in my assignment and my professor said it doesn’t work.

Sorry you had issues :cry:. "We can only help if you tell us what you tried to do; step by step and we might be able to help you." You didn't do that. We do not know what parts of installing work and which do not unless someone tells us. If you decide to provide more information, we might be able to help you get your emulator working with specific advice.

Unfortunate your college professor did not help you get your emulator working. Only you and the professor knows why. Making sure your compiler works should be part of your course he/she helps with.

You "turned in my assignment and my professor said it doesn’t work." How did you finish your assignment without an emulator? You either need to use the emulator or Companion and a real device to live test. Testing is the only way you can be sure the app will work. It is best to compile the Project (build the apk) and test it on an Android device.

We don't know why Alora your emulator is not updating; we can only guess. Perhaps another student can help you get the emulator working; if that is not possible, tell us more about what you tried and what happens (we cannot see your emulator and PC screens). "I did all of that" .. OK, but what happens, where does the process hang up? :frowning: Someone here in the community will try to find out what the problem might be.


Thank you, I’ll ask a classmate to help me.

Another option is to remove the .appinventor folder created in your user directory. This removes everything associated between your account and the emulator. Once you've done that, try starting the emulator again and go through the update dialogs as shown by @SteveJG. If you continue to encounter errors, please include some screenshots and we can advise you further.

esto me paso antes, debes ir a inspeccionar, a consola y debes ver algun texto rojo y clickearle la url de arriba