Camera & timer & save

It makes no sense that it should only work the first time. I have no problems with it. Which device and Android version are you using?

Try both (MOVE and COPY):

imageGallery.aia (55.3 KB)

Both methods work for me (tested: Galaxy Note8, Xiaomi Redmi Note5).

My Phone: Smart Clio L1 / Android 5.1
I also tried this
The result was the same as before
After taking the photo, the photo is stored in 2 locations
Camera & Pictures
But in the Camera section the photo is visible but in the Pictures section the color is black.
Interestingly, in the Picture section where the black photo is shown, the photo details are the same as the photo stored in the Camera section, except that the app_inventor extension is displayed, but no Camera app_inventor extension.
Could this issue be related to my phone and Android version?
Thank you for your efforts

In both versions (MOVE / COPY) no image remains in the "Pictures" folder. I also tested it on devices with Android 5.0 and 5.1. So delete all images in the "Pictures" folder and try again (with my imageGallery.aia).

I'll try again
Thank you

Try this:

  1. remove all images of the folder “Pictures” from your device
  2. connect your device to Companion
  3. click Button1 (Camera1.TakePicture)
  4. right mouse click (on TaifunFile1.FileList), Do it)
  5. if the result (Do it Result) is not an empty list (), post a screenshot


Please see these pictures :

I moved the blocks several times
Sometimes it works correctly, sometimes it doesn’t show the photo in canvas, sometimes it closes after pressing the save image.
Sometimes the image is stored correctly in the Camera area after the application is closed, sometimes with a delayed display in the gallery.
I do not understand the problem !!!
Is it possible to help with the storage process after taking an app photo once?
This is a very complicated issue.
Overall: Can’t a separate directory be created without the app_inventor prefix with the app name?

Why don't you do what I suggested? So use my aia

and do exactly what I said:

and post the result if you don't get an empty list (Do it Result).

Where should I place this block?
Were my pictores wrong?

... it doesn't matter, anywhere

Everything I did, but it didn’t work.
Of course I don’t know if I did anything wrong or right
My English is very bad, so I don’t understand the little things
Anyway thanks for taking the time
Yours sincerely

So what is the result of this block after taking a picture?


Well, I did the same thing, the pictures above are similar to your instructions


and post a screenshot like this

This option is disabled


Off topic:
I see you are using the OpenDyslexic font and that not all contextmenu items use it. I made an issue about that on Github.

1 Like

Yes, disable OpenDyslexic:


and connect to Companion:


Note: I have no problems with that because I always connect via USB:


That’s right?
If it’s wrong, tell me what text to write and where to
Do it Result: ()
I have to put up

As you can see here:

there is no image (file) in this folder:
after taking a picture. The same result as on my devices, so where is the problem?