Bug or Issue in MIT APP INVENTOR (FingerPrint sensor)

Wanted to create a project which authenticates fingerprint sensor.
But on successful authentication image 2 is not showing although it became visible to TRUE but on unsuccessful authentication image image 3 is showing two different things happening but used same logic Why ??


Are you testing with a compiled app ?

Absolutely No

From the extension documentation:

Currently this extension is not able to run in the Companion so you'll need to build a .apk to use it.

I am building .apk file only but then also bug is occuring

Simplify your app. Just work on one screen, and use labels to show your outputs.

If you are getting an error message, take a screenshot and show that here.

No error message but image is not showing of successful authentication which I have uploaded but on the other side unsuccessful authentication image showing.
Everything correct and worked on single screen only and removed clock also then also not showing.
Please run my blocks once
Step 1: fingerprint image opening

Step 2: Putting correct finger but not showing successful image

But showing unsuccessful authentication image when again opened app and runned

After putting incorrect finger it is working fine but on Putting correct finger not showing successful image

Try the test project:

Used different way on one screen then also not displaying .
Updated blocks:

Used authentication successful but not displaying image that means bug but using label it may work but I need image2 to load help

After successful authentication not displaying image2 but on unsuccessful showing image 3 why different same should be

Have you checked the output of hasEnrolledFingerPrints ?

No wait trying Thanks for the suggestion

I tried before which I can remember that everyblock is running inside after successful authentication block but only image2 is not visible but after using fingerprint enrolled block it returns TRUE inside after successful authentication block only image 2 is not visible to TRUE where else I tried in unsuccessful block which works correct and displays image3

Tried a lot Plz check it

Unable to display image2 after successful authentication why?
Extension not executing the display image block
Only blank screen after successful authentication but no problem with unsuccessful authentication

Have you set an image file to image2 ?