Blocks don´t update with different project open(several developers working on the same Project corrupt aia)

Hello everyone,

I am very displeased to see that it is currently not possible for me to work on my project. After reviewing a colleague's project I realized that when selecting my project I would still not be able to see the blocks of my project but that of my colleague's.
I removed both projects completely (including from the trash bin) and only imported my project. However, I still faced the same problem. If I start a new project this is not the case. I guess it has to do with our screens that we have been working on. Both are named the same way as my colleague worked on my project and created an alternative version of it in the same screen I used without renaming it.
Maybe that causes confusion within App Inventor. However, that should not happen.

Have you and your colleague been using the same:

MIT App Inventor login (gmail address)?

or have you been sharing each others aia projects between you?

Have you been trying to merge projects in any way?

You may have a corrupted aia project. Upload it here, someone can take a look.

None of the above but sharing aia projects between us.

Have you been running more than one instance/session of MIT App Inventor in your browser? This is not good practice and can cause issues. You should only run one instance and one project at a time.

I found out about it early on, so I only have one window open in which I work on the app.

Without any information from you, or an aia project file, I can't guess anything else.....

Maybe it causes corruption, certainly. App Inventor is not designed yet for multiple developers. There are several ways several developers can share code . There is file corruption danger with all of them. You found a way to corrupt a shared Project unfortunately.

What to do now? Tim provided some guesses.

  • You could delete the offending Project and replace it with the last known aia file you and your colleague worked on that was 'clean'
  • You could explore the the 'current aia' using PKUnzip looking for duplicate file names, removing them and hoping that will fix the problem. There is a danger when there are more than one cook that the other cook will add an ingredient called 'salt' that the other cook already provided. Using the same variable or Screen name could cause indigestion.
  • if you started a new project; you have no issues (load the last acceptable aia?) Not a great idea, however you already know what was previously coded so build it again, even better :slight_smile:
  • have you made copies of earlier versions using the Designer ( Project > Save project as... ). Be warry of Checkpoint; a good tool but some users have discovered saving too many checkpoint unfortunately sometimes causes problems)
  • you might try renaming the aia that does not load properly. Just click on the yourGreatProject.aia and rename it ourGreatProject.aia . Renaming the file manually might solve your current problem.

Of course you can work on your Project. Just fix the corruption or start a new Project based on what you and your colleague 'learned' not to do. Sharing aia's should be safe, if the developers are careful to back up. There are other ways that several developers can collaborate.

Sorry you have issues. :cry: If you share an aia file, someone might have a try at fixing it.

Look for the Unchive tool in

Maybe you will see something.

1 Like

Also see