aiStarter update MIT AI2 Companion2 to 2.58au

I am going to try it since the self update procedure seems to be caught in a loop on my laptop. It tells me that the emulator is out of date and to press ok to update it. Then the emulator give a few dialogs that says it is updating then it says update aborted and I get the same dialog in the designer that says the emulator is out of date and the process starts all over again.

Hello. I tryed that out and it didn't fix the issue:

Platform = Windows
AppInventor tools located here: "C:\Program Files (x86)"
Bottle server starting up (using WSGIRefServer())...
Listening on
Hit Ctrl-C to quit.

I could get the emulator oppening with the app "MIT", doing as described here. But it still doesn't connect to the MIT site. Do you know how to fix this problem?

Did it work for you?

Which Project->Connect option did you use from an AI2 Project to try to connect?

I always use this way:

I don't see a solution to your current symptom, but there are workarounds involving different emulators.

I personally use free MemuPlay (ad-supported), and load the Companion .apk file onto it whenever a new AI2 version comes out.

My connection technique is through Connect -> AICompanion after starting the Companion app on the MemuPlay emulator, and I copy the 6 letter code from AI2 and paste the 6 letter code into the Companion app.


1 Like

Thanks! It's a good option using an emulator. If you don't mind, I would tell you my worries:

That's my point:

I'm a teacher in Brazil and I'm supposed to teach my students some projects. I was doing them; I test them with my android device (I tried to use my Iphone 7 plus, but in this specific project it was getting me a long time, so I decided to give it a try on the Samsung S6. It worked just perfectly!). And then I show to my students.

For a while, we are having online classes, so the students can use their own computer and devices to try the apps. But in the school, the computers just don't open the emulator nor conect with cellphones. I could make one single computer open the emulator and it worked fine last month when we were at school, but the students couldn't make it work in the others computers in the school.

In my personal computer (where I am now) I could always use this aproach with the emulator. So I could share my screen for the students besides openning and running it on my cellphone (so I took some photos and made some videos of it working so the students could see).

I need something that could make the emulator work properly, because if I suggest MemuPlay I don't think the school would let me download and use it. The students just would install lots of games.

If you have some suggestion, or if you could explain me this "dance":

I would give it a go.

Thank you for the help so far.
:+1: :+1:

You might talk to you school IT department.

Here is advice for IT departments School IT/Network Admins: Information specific to school networks (also helpful for conferences and hotel situations)

This is probably an issue where your IT is blocking students but not those with special network access privileges (like teachers/instructors). Your IT people may be blocking ports 8001 and/or 8004 or they might even be blocking the MIT web page. Ask IT to whitelist. I suspect IT is blocking access to aiStarter and the emulator. :frowning:

Here are discussions where teaches had issues with the emulator and students had difficulty accessing App Inventor on school networks Search results for 'schoolnetworks' - MIT App Inventor Community . Several of the links discuss how some teachers solved their problems.

1 Like

I found an astonishing number of emulators at 41 MEmu Alternatives – Top Best Alternatives with varying performance ranges and features, that you can customize.

Follow SteveJG's school advice.

1 Like

See minute 3 of this video:

You need a big PC screen to see all sides of this conversation between the user and AI2 and the Companion. Switching among them is the dance.

I could do this in the past. I had to do this procedure in order to update the emulator and use it. But now the problem is that it doesn't connect to the MIT site at all...

Thanks for the video! Now I remember the dancing part of it.

That will help me a lot! Thank you!
And for my personal computer, do you have any idea about this problem? I tried to delete the aI program and dowload it and install again... but it didn't make a difference.

Sorry Juliana, I do not understand what you are asking. You said the emulator is working with your personal computer .. are you using all the advice here Installing and Running the Emulator ?

What specifically is not working? Are you loading a Project? Try loading a small Project, not the one that is not loading into your emulator and tell us, step by step what happens.

No, it is not working... it worked some weeks ago, but now it doesn't connect to the MIT site. It says there is no aI installed, but it is.
I will show you! First, I open the aI program and get this message:

Then, I try to use the emulator in the MIT site:

It tries to connect:

It says there is a problem:

Then I have this final answer:

Thank you for the images; they are helpful.

Did you download the aiStarter software to the default C drive folder? What you are seeing could be the result of downloading aiStarter to the wrong location. Here is where the software should have installed on a Win10 laptop.

Is this where your aiStarter.exe file is located? The setup software won't find the emulator support if it's in a different location.

The first message you see (with the black background) is correct. That is good.

The advice here Help Connecting the Emulator might help.

Have you installed any virus checker since the last time the emulator worked?

Try the advice in the link and let me know if it helps get the emulator working.

Yes! It's in the C:

I installed th CCleaner! Maybe that's the problem??

Ok. Is it in C:/Program Files(x86)/AppInventor as shown in the image and do you see the files indicated?

Maybe. CCleaner is a utility used to clean potentially unwanted files and invalid Windows Registry entries from a computer. A tool like this could cause issues, depending on if it decided one of the aiStarter files is an issue. Sorry, I can't tell you it is problematic or not.

Yes, there are all there!

I dont see a commands-for-appinventor

Post a screen shot of what you DO see.