AI Companion fails at 20% loading

The MIT server is still having technical issues. We do not know how long this will take to fix however there are several relatively easy ways to continue developing despite the MIT server issues.

  • check Use Legacy Connection on Companion before scanning the QR code. Checking works for most developers and will get you past the 20% loading issue.
  • use the emulator. Yes the emulator works.
  • use the USB connection option
  • compile your app and test. Tedious but several users say it works. :frowning: If you are not an advanced user, I do not recommend this.

Try these options and tell us which work.

MIT is trying to fix the server issue, MIT is replacing existing server hardware. This work may take some time. This might not be fixed for several days. Please be patient; eventually the server will be back to normal. However most developers can continue to use App Inventor using Companion with Legacy checked or one of these other options until full service is restored.

Hi Zeba,

I saw SteveJG replied already. I have not gotten it to work, and I too am stuck with my students who cannot test their final projects as they code. Sounds like we wait. I have had a little bit of intermittant success by checking the "use legacy connection" box, but not much.


Legacy checked makes a difference. It hangs at 92 percent as opposed to 20 percent.

I am trying to get emulator to work. Going to roll back to a known working app, give it another try.

Hello !
Since today without having made any changes, I have encountered a connection problem between and my phone
As a precaution, I reinstalled the application on my PC, try using the Use Legacy Connection mode, nothing to do the transfer hangs at 20% "20 Establishing Secure Connection"
Can you tell me how to find the functioning of APPInventor.
Thank you

App Inventor 2 is a Web application. It is not installed on your PC.

App Inventor is functioning now. It is not functioning normally because of a massive server issue MIT is trying to repair. Developers can use App Inventor now in several different ways as described in the above posts using Companion with the Legacy box ticked, using the emulator etc.

App Inventor is now using alternative servers until the main server problem is fixed. These alternate servers do not work normally but do work using the work arounds.

How long will the problem persist? Sorry, we do not know. This could last all week or be fixed in hours. :cry:

Four options to try:

  1. Legacy mode → works for me
  2. USB connection → works for me
  3. (with Legacy mode) → works for me
  4. AI2Offline (Companion or USB). → works for me
    (Note: The package of the generated apps was changed from "appinventor.ai_" to "com.")
Option 1-2

Since all options work for me, others should be able to do the same - at least with one of these options.

1 Like

If I try Companion without "Legacy" checked, it hangs at 20 percent. Indefinitely. Legacy checked? Much different, hangs at 92 percent. Indefinitely.

The emulator is so slow I do not know if it is working or my app is hosed. It never gets to the opening screen of my app--which it absolutely does if I can get Companion past 20/92. Which happens once in a while. Good part of the time, it cannot find "aiStarter". Sometimes, it does. I have zero confidence in this solution. Haven't used it before, so don't know quite what to expect. It seems to work (slowly) with simpler trial, debugged, apps.

As far as USB connection. My device I am using for debug doesn't have a driver. I have other devices that might. I am getting fed up with dead ends.

Color me dead in the water, for all practical purposes.

It would be nice to have some idea when this might be fixed. Or, if.

Have you tried the options in a different browser: Firefox/Chrome/etc...

Good suggestion. I use Chrome, it has worked. In the past, I concluded Edge did not. It may have been Edge's problem, may have been mine.

I will give Firefox a try. I have it loaded, don't use it much.

Desperate in San Diego


Gave Firefox a try. No apparent difference.

Thanks, Gerg, use legacy did not work for me. it is reporting a bug when I clicked on use legacy witghscan with code. But sometimes it's loading and sometimes stuck.

Thanks, SteveJG for your valuable suggestion. Still facing issue with connection.

Most other developers can successfully use one of the suggestions to connect until MIT fixes the server. I don't know why you and several others are not able to use Companion with the Legacy option ticked.

  • are you using a school network? Your IT may be blocking. Have you tried using a different Internet connection? Possibly a home network if you are using a school network
  • your Project could be large (and timing out). Can you load a small Project successfully? It is possible you have issues with your Blocks that are creating problems.
  • your virus checker or your router or a slow Internet connection could be causing issues. Do you have DSL?

What does the error message say? Sometimes loading and sometimes stuck might indicate an issue with lots of Blocks or files or a very busy time. Certainly the number of users attempting to build simultaneously could be part of 'your' problem.

In my case, I have a slow internet connection. On the order of 3-5M. Decent ping time <20ms. Nothing has changed as far as routers, firewalls, interconnection speed., etc.

unchive says I have 1900 blocks and 637K of assets. That was before I deleted some stuff.

The error I get when Legacy hangs is:

Sending assets/external_comps/ to companion

I deleted some png's I wasn't actually using and it seemed to lower the hang point from 92 percent to 87. I have an image a text file and a .wav.

Back when it was working, the whole thing would load in five seconds, or so.

I can imagine that there a whole bunch of users banging away trying to get in.

Maybe one of the assets I am downloading is hanging it? I will delete the image and .wav for now and give it a try.

Edit: Deleted everything except the .txt file (small). Hangs with same message, just at 75 percent as opposed to 87 percent. Is it the BLE extension that is hanging this? If so, I am truly out of luck--it is a ble app.

What happens with an empty project?

Tried with a small, known working, no BLE extensiont. No progress bar, after a time I get "Companion Connection Error: "

This project loaded fine a couple days ago.

Things are deteriorating. It is time to quit banging my head against this wall.

Thanks to Anke, Steve, TIMAI2. Really appreciate your help. Some days I am just snake bit.

I used the emulator for the first time. I had to install it as an administrator. Restart the computer and after the installation setup, I have to say. EMULATOR IS SO MUCH MORE CONVENIENT and FASTER. Thanks @Anke for the posts.

1 Like

Regarding the classroom impact, here is an alternative work around to live testing:
Have your students do Structured Walthroughs on their code, based on Downloaded Blocks Images, screen captures of their Designer views by Arrangement and Screen, and separately prepared documentation of their data structures and data flow.

Peer review is as valuable a skill as live testing, and a productive use of class time.

1 Like

I have the same problem
How resolve?

See post #24.