YAIL and AAPT execution Failed

We've already tried... We removed all Screens, practically erasing everything that was done and the error persisted. We also tried with only 3 screens, 4 screens, etc., and the error persisted.

I did not understand.

I've seen such problems. What could this be caused by?

you install project as extension

1 Like

And this is the evidence of it

Someone changed their name from aia to aix and downloaded as an extension?

What extensions did you add to the project? Were they files with aix or aia extensions?

No, the download was done in AIA and has not been changed in format or name.

AIX, but we deleted the extensions (two extensions), and removed screens in different orders, and the error persisted

We created the project. The added extensions were for alarm and reminder with push notification, only they were added to our project.

Without sharing the project with someone, we will not find out where you made a mistake.

If you wish to check whether there is a project in project check

1 Like

We saw the topics you indicated yesterday. Another reviewer suggested these and a few more, but this is not our case.

Unfortunately I can't share it yet... It's in this year's MIT AppAThon competition.

Sending it to a poweruser is no problem.


Unfortunately, the project is broken. All you can do without sharing is to create a new, empty project, then copy the layouts and blocks from the old project to the new one. Screen by screen. After copying each screen, check if the project can be compiled.

Just to be sure, open aia with 7zip or win rar, and post a screenshot of external_comps folder ?


@Patryk_F We tested it here and it worked! Thank you so much for your help and everyone!
@Peter Thank you too!

1 Like

My problem has been fixed by this hint. Thx.