Why can't I start the emulator?

I am unable to start the emulator. It shows "starting, this will take a minute or two" but then it shows this:


aiStarter is running


What is the problem here?

Searching didn't help.

I am using laptop, windows 8.1, Lenovo IdeaPad s510p (2013).

50+ results


Didn't help.

Multiple users are experiencing this and similar issues with the emulator recently. MIT does not know why some users have this and similar emulator issues yet.

MIT are aware of current emulator issues.


Ok, until then, I will use Bluestacks. :slight_smile:

When you're connecting to the emulator, do you end up seeing any errors in the browser developer console? It's interesting that neither the /ping/ or /echeck/ calls, which are necessary to start the emulator process, aren't being logged in the aiStarter window.

1 Like


I see these errors, but I never blocked anything.

Thanks for the information. Are there any extensions in your browser that might be blocking it?

I have a built-in extension that can be turned off. It is called "Brave Shields"


I don't have any other extensions.

If you turn that off temporarily, does it still fail to connect?

As far as I have tested a few minutes ago, yes, it still fails to connect. I have also reported the extension developers of this problem.

It's likely something else then. In Chromium, Google is starting to block access to local network resources. They provide a mechanism for us to opt out of this in Chrome, but Brave may not be respecting this. If you have Firefox, I'd be interested in seeing if you have the same problem in Firefox.

1 Like

Brave is based on Chromium.

This never happened before I upgraded this laptop.

I do have Firefox. After testing I got this :frowning: :

It tells me emulator is started but emulator window isn't showing.

1 Like

I am back on this topic because I still get this issue. I waited for a long time. I get the same error ;(

The browser name is Brave, not chrome.

When was the last time you used a Chrome Browser (not Brave) @AyProductions ? The emulator on my Win10 suddenly started working again on August 26th after several months of failure I use Chrome.

MIT patched aiStarter about this time. You might try the emulator using Chrome. Let us know whether you are able to use the emulator using Chrome. You might have a different issue but I want to say this is now working for me.

~7 months ago (I switched to Brave due to private reasons)

I did get it working on Edge, the BETA emulator version from '19.

It is working in Chrome with me also.

It is supposed to work on Brave though.

In Brave, it never worked, but now after a long time, it works. Maybe because I upgraded the emulator? Not sure why.

Google is making a change to Chromium, which underpins Chrome, Edge, Brave, and other browsers, that prevents websites hosted on the public internet from talking to services on a private or loopback network. The reason behind this change is that malware authors would serve malicious JavaScript that would exploit bugs in routers and other network equipment. However, this is also the primary mechanism by which App Inventor implemented legacy mode and emulator support. For Chrome, Google has a channel by which we can request temporary exemptions until the policy goes into effect full force in October. The latest 2.64 companion in the Play Store, the beta version of the iOS companion in TestFlight, and the upcoming emulator package are all aimed at addressing this policy shift. Meanwhile, Firefox and Safari should be unaffected because neither Mozilla or Apple to my knowledge have signed on to this change.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.