Web Component GotFile Broken

Not sure when it broke, but it is now not possible to download a file using the web component. Tested with image and text files from a standard file server and google drive.

At present, GotText still seems to work OK.

webComponentTest.aia (1.9 KB)


And it works with SaveResponse = false? Maybe the saving is causing the problem?

From the error message, it appears that it is not connecting to the file in the URL, this is before we even transfer the file

Maybe component is still following legacy storage modal.

I tried setting Scope to Legacy (and Shared...) but this made no difference.

Probably that doesn't matter as file obtained from FileUtil.getExternalFile() belongs to DefaultScope, by default.

Thanks for the report @TAIMAI2. I'll put it on the list to work on today.

We really need help. Thanks!


In Android 9 it works for me setting a name in ResponseFileName.

Works with Screen1.DefaultFileScope
Legacy, App, Private, ...

borrar_bajar_arch.aia (2.1 KB)


Yes, it works if you give it a filename, but you should be able to download without giving a filename, AI2 will create one for you. (unless it has suddenly fixed itself...)


Any news here?

Error 1101 is still present when trying to reach a file on a server using WEB component

We are aiming to update ai2-test today with bug fixes for the various components affected by write permission issues in the new release. The web fix should be included as part of this update.


Tested today on the test server and it still does not work!

It still gives error 1101 unable to get a response with the specified URL


Just compiled and installed on Android 11 device

Works with a filename supplied, saves to ASD, but does not work if no filename is provided


In my case, I have tried providing a filename and it doesn't work either, it gives me the error.

1 Like

Note that if you're using the test server, you also need to install the test companion from that server. If you're using companion 2.61 or 2.61u, that companion corresponds to the nb187 release.

1 Like

Any news concerning the Web.GotText Problem?

You can check back here for latest release information


A proposed fix is available on ai2-test.appinventor.mit.edu. If you plan to test with the companion app, you'll need to sideload the version provided by that server under the Help>Companion Information menu. The version number of the test companion is 2.61t2u.

Dear @ewpatton,

Thank you very much!!

The Problem still exists on the TESTSERVER:


results in: