Way to Ignore 1103 error message and continue?

Building an APP via USB companion device.

The App code I am working on is connecting arduino to wifi network. Since I will loose internet access

Step 1 -> connect device to WiFi network of arduino AP.

This works, I successfully connect to Arduino wifi.

Step 2 -> hit a setup button in the APP. Which then makes a json call to the Arduino. The arduino scans for WiFi SSIDs and returns a list via json.

Step 3 -> arduino builds a dynamic list based on response key list SSID.

Again, I am connected to my companion via USB, because I know I will loose internet access when I connect to the arduino wifi, which is the whole reason I chose USB.

Step 1 works, I can connect to arduino wifi.

Step 2 works, I see my APP sending json call to arduino, and the arduino scans wifi networks, and returns SSID json list.

Step 3 FAILS. I am getting pop up message in my APP. Error 1103: Unable to complete the given request with the text.

The 1103 error is occuring before my APP can build the lists from the json response.

From my research, it appears that the MIT App inventor is somehow trying to use an internet connection (instead of USB) to talk to the rendevous server? so it fails with this message??? I think that is what is happening?

Is there a way to tell the APP to ignore the 1103 error so my code will complete? not having internet access is 100% known prior to coding this. It is the whole point actually, connect to a "private" wifi so I can then send configuration data about the correct SSID / password to the arduino so it can connect to the internet.

The rendezvous server is needed for the Companion.

Build the app and test it alone.

Why is it not using the USB connection to my computer to talk to rendevous? Seems like a huge design flaw in the USB companion. Plus a huge waste of time having to compile APK and then load it to device just to test code...Which may need to be done 100 times before code is completely right. That's why its called "testing".

If I can simply ignore the 1103 error and let my code continue, it would be better because I know the arduino is sending the json response, I need to continue.

This is everything I could tell you about the Companion.

I just loaded the APK on my device, and still got the 1103 error....

Unsure why this is failing still. 1103. compiled and installed apk.

this is the json response from the arduino


I was able to fix this. even though the 1103 still occurs.

found my arduino was not sending appropriate json response. used PCAPdroid to run an network trace on my device.

After fixing arduino json response

worked on my dynamic component button display

I still get the 1103 message but it goes away and I get the result I want.

Button for each SSID found when the arduino did it's scan.

This is running a USB companion BTW

Screen1 has an error catching event block where you could hide the 1103 error, if that's all you need.