Void (Voice) control to firebase

I am importing voice data into firebase to control esp. When I make words as numbers it works. it doesn't work with letters. help me


Need to focus on what happens without Firebase.

What is your Speech Recognizer result when you try words ?

I said "hello" but firebase doesn't show up. When I entered the numbers it was displayed again

You may have said "hello", but what is the value in Speech recogniser Result ?

Not showing results on firebase. But still shows on mitapp

TO_TEX Show hello . No data pushed to firebase

Sometimes the SpeechRecognizer has difficulty understanding single word responses.

Have you tried this tutorial?

1 Like

Ah, just spotted the problem.

You need to put the speech recogniser result in double quotes, it is a string (which is why it works for a number / integer without quotes)

What will the program look like? Can you write down an example to help me fix it


1 Like

it worked. i will continue the project with esp32. I will need your help when needed, many thanks

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.