Uninstall aiStarter on Windows 10

I've just discovered App Inventor - it's wonderful!

To try out my first project I wanted to use the Emulator, so installed aiStarter. When the emulator started, and the phone simulator appeared, App Inventor gave me a lot of instructions about applying updates before ever getting to trying out my creation. It's now stuck - I can start aiStarter but it doesn't connect with the App Inventor web page. I've Reset Connection. I've also tried reinstalling the software but it throws an error because it can't overwrite one of the dll files. I wanted to uninstall it and start again but it doesn't appear in the list of apps in Windows Settings, and there doesn't appear to be an Uninstall option in the program folder.

Grateful if anyone can suggets a way out of this. Thanks.

Search for MIT App Inventor Tools 2.3.0

If by any chance you do not find it, try to locat it

1 Like

Thanks for the reply. There is no entry under Apps for MIT App Inventor Tools and the program folder doesn't have an uninstall.exe.

Do I need to restart the computer to be able to find this?

Restart your computer and check again

I restarted the computer and was able to reinstall from the installation file. There is now an uninstall.exe present and the app is in the list.

I went through the process for upgrading Companion but now it's stuck trying to download the CompanionUpgradeHelper. The App Inventor website was saying repeated that it was waiting to see if the Companion was running and now it says it's unable to connect to the Android Emulator.

The phone emulator just shows this endlessly:

Your firewall might not be letting the emulator make outgoing network connections that it needs to download the latest update. If you're continuing to have trouble, you may want to try beta testing the newer emulator package if your computer supports it as it is faster and won't need to do a companion update:

http://ai2-buildserver-nightly-ewp.csail.mit.edu/setuptools-beta/MIT_App_Inventor_Tools_26.255.0rc1_win_setup.exe

1 Like

Thanks for this suggestion. What do I need to do in the Firewall to set an exception? Is 5554 the port number?

I have also downloaded the beta version and will experiment with that today.

aiStarter.exe and emulator.exe (the exact name is different depending on which version you're using) need to be allowed to make outgoing connections to ai2.appinventor.mit.edu on port 80.

I've tried adding these two programs to Outbound rules in the Windows Defender Firewall, but it still hangs on Initialising download.

Hmm. Not sure what's causing it to be blocked then. You can manually do the upgrade following these steps if you'd prefer:

  1. Start the emulator, but close the ai2 window once it's up and running. This will prevent ai2 from stopping the emulator if the update fails.
  2. Download the latest companion from this link: http://ai2.appinventor.mit.edu/companions/MITAI2Companion.apk. This should end up in your Downloads folder as MITAI2Companion.apk.
  3. Open the Windows Command Prompt by pressing Windows+R, typing cmd.exe, and pressing enter.
  4. Type in the following and press enter, or copy it and paste by right-clicking in the command window:
"C:\Program Files (x86)\AppInventor\commands-for-appinventor\adb.exe" install -r Downloads\MITAI2Companion.apk

This should initiate a transfer of the companion APK to the emulator and start the installation. After installing, your companion version will be 2.60u. If you encounter any errors, please include screenshots of the command prompt in your reply.

Hi Evan

Thanks for your help. No success yet - here is the command window after trying to run adb.exe:

Here is the emulator while this was going on:

Oh. Sorry that is my fault. I gave the URL to a version that is not quite compatible with that version of the emulator. Please use this link instead: http://ai2.appinventor.mit.edu/companions/Emulator.apk

And in the command I gave you, replace MITAI2Companion.apk with Emulator.apk to select that version.

It's working now, but curiously it turned out I didn't need to install Emulator.apk - for no obvious reason when I started the emulator today it was able to download and install the update to Companion Helper without hanging. Many thanks for all your help.

By the way there is a help page for emulator problems with Windows OS:

http://appinventor.mit.edu/explore/ai2/connect-help-emulator

and in the third paragraph there is a link to a page called Debugging issues in running the App Inventor Setup Tools and the emulator on Windows but this link is broken - it says the requested file has been deleted. Do you know if this is available at a different URL?

Thanks

Confirmed.

There is a Power User FAQ at


you can check while MIT deals with their link.

Unfortunately, I'm not sure who owned that document originally and what its contents might have been. We'll probably need to recreate an FAQ on the website with important information.