Undefined Variable. Irritants (yail/yail-dictionary) (when using iOS but not when Android)

I am attempting to create a basic Sign/Log in system. Previously I had a few issues with lists duplicating when communicating with a CloudDB. However, when I switched to the new IOS app, this error message repeatedly shows. Err
(Undefined Variable. Irritants (yail/yail-dictionary) Note: You will not see another error reported for 5 seconds)
I have checked repeatedly through my code and no variable is undefined, and "YAIL", from my understanding, is the language used in MIT App Inventor.
Aforementioned code:

There isn't any example in your screenshots of the use of a dictionary. Are you sure this is all the code related to your app?

Yes, there are no dictionaries used, and this is the screen that is having the issue. I have minimal code on the other screens but none with a dictionary.

Ok. Would you mind posting the AIA here or PMing to me so we could investigate further?

Not at all, thank you!

Hi there.

I'm working on a voting app that allows you add items to the list and the select the item and add 1 vote to the item. I am also using ios and got the same error and I am not using any dictionaries. Does anyone know exactly what the error means and how to fix it?

Thanks

Are you also using CloudDB for your app? If not, how are you sharing the votes between apps?

I am not using any form of storage and it is all in one app. I used to use an android device to test my apps and i wonder would you need to use the CloudDB storage instead of the TinyDB on IOS?

TinyDB should be fine if you're just doing things locally. If you could send me the AIA file I can take a look.

We've narrowed down the reason for this issue and a fix is in progress.

1 Like

I've run into the same problem without the use of any dictionaries. Has the fix been found?

1 Like

Any solution to this error?

Please wait for the next version of App Inventor. If it is fixed it will be in nb189 probably sometime in June/July.

Hi there,

I'm working on the fitness tracker challenge app, and it keeps showing up. Everytime I try to get it to show data, it shows that pop-up. Do you have any idea why? I'm not using any dictionary. I'd appreciate the help.

All the best,
Tiana Brown
Solar Prep School for Girls

Are you using ios? Please read the earlier posts. This issue is NOT fixed yet.

Do you see an error when you use the Android Companion or the emulator?

If you do not have an Android device, perhaps borrow one and test. I suspect the error is not present on Android devices.

I am also facing the same error. Has the fix been issued now? I am not using any dictionary either.

If you test on the beta version announced here, you should not encounter dictionary-related errors. If you continue to encounter issues on the beta version, please report them so we can fix them.