Unable to run aiStarter (No such file or directory) (Linux)

So basically I am trying to follow the tutorial and I can't get it to work. I assume this is because of 32 bit support but I am also unable to install it so I am clueless about what to do.

You can see it is properly installed and aiStarter is in place with the right permissions:

However, when I try to run it, I get this back:

I tried to install support for 32 bit software, but when I enter the command, I get this:

I would use the web version but I need to install it locally for a school homework. It specifically asks me to install App Inventor on a Ubuntu 20.04 virtual machine so I can't change versions or install it on an actual machine.

This worked for me but was on a x64 machine

I just tried that and I get the same issue when I get to the lib32z1 step.

According to the instructions, you shouldn't need it:

Note: The setup programs are 32-bit software. If you have a 64-bit system you may need to install libraries the let your machine run 32-bit software. One way to do this is to run the command sudo apt-get install lib32z1 , but this might not work on all GNU/Linux distributions, and you may need to do some investigation for your particular system.