Ubuntu 20.04 LTS install App Inventor simulator ?



When watching a video, choose a high-resolution view, it will be much clearer.

operating system: ubuntu 20.04 LTS

Installation command:
sudo apt-get install lib32z1
sudo apt-get install lib32stdc++6
sudo dpkg -i appinventor2-setup_2.3_all.deb

What is the reason for the unsuccessful installation?

I have just tested the installation process, and it worked fine for me:

sudo rm -rf /usr/google/appinventor
sudo rm -rf ~/.appinventor
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install lib32z1
sudo apt-get install lib32stdc++6  >> "latest version already installed"
cd Downloads
sudo dpkg -i appinventor2-setup_2.3_all.deb
/usr/google/appinventor/commands-for-Appinventor/aiStarter &

Both emulator and device via USB worked


After the simulator is upgraded, there is a problem.
The simulator has been stopped at the place of the picture.

How long have you waited, this part can take some time...

After waiting for a long time, there was no response.
Why is there a picture situation?

?? explain ?

When doing Companion updates, move the emulator window to the side so you can see if the AI2 web site has popped up a confirmation dialog.

Re-record a video

Why does the picture above appear? What should I click?

After the emulator is upgraded, should you click open or done。

You should click Done
and allow the emulator to restart

Why does the situation in Figure 2 appear?
Figure 2. Click "force close", or "wait".

Re-record the video


When installing the emulator, the picture appears.
The emulator still cannot be installed?

Try this ?

I'll suggest to use genymotion or android studio emulator (for Linux) or Memu and Bluestacks (for Windows).

ubuntu20.04 LTS system, no directory: C:\Users\USERNAME

After changing the App Inventor source code (non-APK program), will the android studio emulator display the modification result instantly?

You will have to manually refresh the companion if do a non ui change.


Conditions for installing the simulator:

  1. Install under windows system.
    The operating system must be one of Windows XP, Windows Vista, and Windows 7.
    Other windows systems, such as windows 10 can't. is not it?

  2. Install under ubuntu system.
    Only supports wifi connection. is not it?

Emulator and USB work for me in Ubuntu

Operating system: ubuntu 20.04 LTS
USB, success.
Video link:



Operating system: ubuntu 20.04 LTS
WIFI, failed.
Video link:



The computer ubuntu 20.04 LTS is set as a hotspot.
Android phones connect to computer hotspots via WIFI.

Is there a problem with the WIFI connection between the computer and the android phone?

The debugger stops at 20%, why?