Unable to connect to emulator error "cannot use two codes with one startup of the Emulator"

Emulator scans the QR code and progress reaches 20% when it stops with Emulator warning "cannot use two codes with one startup of the Emulator".
Uninstalled and reinstalled Emulator.
Refreshed Chrome browser page.
Tried a diff .aia
half an hour later still cannot connect.
I have used the same emulator many times, many years, many .aia's
This is a 1st.
Lack of google results suggests recent BUG !
PS It pops up in emulator as a WARNING but its an ERROR that causes no connection to be established.

I have seen similar complaints about not ending the Companion app before trying to connect to the Companion again.

it seems that you don't reset your connection after testing, try to close companion using Reset connection button

  • Try to close companion and open it again

  • Try to clear companion data

  • Try to reset your connection

Did that several times including Hard Reset.

Previously I had the companion open with an AP on my phone for many days.
But surely uninstalling it and re-install would have cleared any issue remaining on the phone ?
I uninstalled and reinstalled the Companion again. Deleted teh chrome tab for MIT AppInventor and launched it in another tab. Hit reset connection first. Launched the Companion. Reset connection again. Did the connect QR Code and scanned. It gotto 20% again and this time I got NETWORK ERROR. Not the error"cannot use 2 codes....".
Tried again and this time got the "cannot usse 2 codes..." warning. (Not loading to 20%) The QR code just remained o n screen.
On the phone I clicked OK forthe warning ( which then went away) and at the same time the AppInventor on my PC QR code disappeared. So the PC is getting info from the phone.
But all retries continually stop at 20% with "Establishing a secure connection" and Network Error "The companion has disconnected".
And subsequent try: ----- load to 20% and "cannot use 2 codes..." warning on the phone.

  • this can be an internal problem of companion
  • it can also be related to the information stored in the phone/tablet
  • or your 2 tabs are connecting at one time

If I can take a detailed look at the photo/video of the error, I can diagnose the problem much faster, so could you please record/take a picture/video of error and upload it here?

I double checked my 2 windows of Chrome with 40+ tabs to see if there was another https://ai2.appinventor.mit.edu/#xxxxxxxxxx but only one.
Nevertheless I killed Chrome in TaskManager and restarted it ( thankyou google for restoring all tabs) AND THAT FIXED THE PROBLEM !
Thankyou for following this problem and keeping me trying everything to fix it.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.