Unable to Connect to Companion App on iOS


For about a month, my students and I have been unable to connect our apps to the iOS companion. After scanning the QR code, App Inventor's connection progress gets stuck at 10% with the message "10 Found the Companion". This doesn't happen on Android devices.

Any ideas?

Thanks in advance,
Greer Pedoe
I. E. Weldon Secondary School
Lindsay, Ontario, Canada

Does your school include any forced extensions in Chrome? A recent thread I saw in Mobile CSP suggested that an extension called GoGuardian is preventing the popup window from working correctly.

Thank you for this info. We have a lot of forced extensions added to Chrome. I'll see if that's one of them.

Thank you for this info. We still get the pop-up window and they can click the button to background it, but I noticed the problem started after the pop-up window became part of the connection procedure. I'll see if I can dig into it further with this in mind.

Before I dive into the extensions we use, I want to make sure we've whitelisted all pop-up related sites. I've had our board's IT department whitelist these domains for pop-ups, and still no luck:


Are there any other sites involved?
And does ever change?

Thanks again,

For the pop-up, no. There's the rendezvous server at rendezvous.appinventor.mit.edu, which is used to exchange IP addresses so that the computer and phone can talk to one another (via the popup), so as long as the pop-up is appearing that step is already working and completed. The IP address will be the IP address of the student's phone, but these are private IPs within the school's network in order to keep the traffic local.

You may want to share this document with your IT:

Thanks again for your help! We'll work through that document and see if we can get things sorted. My students and I appreciate your time!

As a side note, we got the connection working between AppInventor and iPhones through Edge. This certainly makes it look like there's some extension on Chrome messing things up.

1 Like

Thanks for that information. It's useful to know about these workarounds. We're also working on getting the WebRTC connection method deployed for iOS so that it behaves the same as Android.

We did some testing today. Looks like the " Read&Write for Google Chrome" is responsible (at least for us). We disabled JUST that extension and it started working in our testing. No students today or tomorrow but we'll find out for sure next week.

More updates! We also found that it was Read&Write for Google Chrome causing our problems. Unfortunately, our board does not allow us to disable it. However, in working with them we discovered the following (from my discussion with our IT staff):

"We push the R&W extension in 2 different ways.. We use the Google Console to force install the extension via the user profile signed into Chrome. (This is the one I was able to turn off , and then the app started to work)

We also push that extension via GPO (Group Policy) for our Windows devices (device based) so that even users that do not sign into Chrome get the extension. (If I open Chrome without signing in R&W will still show up on a Windows device). It is not the same as the one applied through the Google console, and this does not appear to break the process.

The downfall is, we cannot use the GPO method to apply the extension to Chromebooks, forcing us to use the Google Console to do it.

I also compared all other settings in the console side by side by side for my test account and one that did not work.. and everything was identical, the only thing that fixed it was disabling the R&W extension that was set to be applied to users via the console."

Maybe that will help those of us who can't disable the extension?

Thanks again for all your help -- here's hoping you can get the WebRTC connection working for iOS again!

Is it still working through edge?

Our students use Chromebooks, they don't have access to Edge anyway. Something in that extension is stopping it. I am not sure if it would stop working in Edge if the extension was installed or not.