Trouble connecting to MIT

Try opening MIT AI2 on an Android Device by directly going to the link If it works, download an Android Emulator and do the work there until the AI2 Offline problem is solved.

aia loads just fine

pictures, html, etc fail. It usually crashes on the first file of the file list but sometimes second or third.

This does not happen in just one aia but all.
It does not happen with only the offline version but the online also.
All of the apps have been fully successful with no internal errors.
All of my apps are being used daily and run flawlessly.

Yes there have been successful loads, obviously, and successfully compiled.


If you downloaded and unpacked the portable version of AI2Offline 3.9 AI2Offline3.9.7z

take the following screenshots and post them:

  1. Java / JDK

  2. Directory where you unpacked AI2Offline

  3. JAVA_HOME (environment variable)

Without seeing these screenshots of yours, I won't make any more comments.

1 Like

Another question Wes (sorry we are accelerating your hair loss) : What Browser are you using?

1 Like

Haha! no problem Chris I have read your good help over time and my commendations. I may be 73 but in perfect health and still must cut my hair every 12-14 days. The wife says I have too much hair (on my head not my ears, nose or other elderly complaint areas) :joy:!

Firefox latest version is your answer thanks

Firstly I can not get Oracle Java. I did use @dora_paz 33 above java and it located in another path.

I tried about 30 different combinations of configuration already. What I have does work but I have the one single error when trying to load assets. I get the same error with online version too so I dont think its my configuration at this point.

I will try to get those screenshots for you soon. Its the weekend and my kids are pulling on me so ASAP ok? Thanks @Anke

Here is a direct link (to download jdk-8u202-windows-x64.exe):

1 Like

Till now I thought that you are unable to connect to the AppInventor server. But now I understood that you are talking about the Companion.

In that case try the code-ai2 website for MIT AppInventor. Its companion is different and downloable from that website I think.

Finally I got the real thing it seems .. time will tell .. Thank You

I installed 3.9 Executable (AI2Offline_x64 installer.exe) and this is the result:

Control Panel\System\Environment variables:

Thanks but I continually get error that link is "site not found"

This is because @SHUBHAMR69 posted the incorrect url. Although it appears to be slightly off topic with what you are working on (an offline version), here is the correct link:


WOW and good to see you @TIMAI2 ... thanks much for that !!!!!!!!!!!!!!!!!!!!!

I successfully ran the companion 5 times in a row !!!
It connects rapidly and I do NOT get an asset load failure!!!!!!!!!!!
This PROVES that my asset loading errors is not due to any configuration problem on my PC

I still would like to get Offline version working however because I spend much of my year in a remote primitive village with a weak connection.

REALLY NEED OFFLINE .... presently it works but fails to load assets and crashes

WHY? Why is it I can ping for hours getting 100% signal strength and 50 ms round-trip response but I can NOT connect? Obviously my request reaches MIT but it will not answer!!!!!

ASSUMPTION: MIT is full and rejects many requests. So why not send the user a message saying it is overloaded? Send some sort of message so the user is not sitting like a dummy staring at a foolish screen? :rofl:

There must be something going on locally in your computer, because this is not a widespread issue. MIT is not full, millions of people regularly connect to the ai2 server.

Things to try...

  1. Confirm using Chrome/Firefox
  2. You can try completely clearing your browser cache.
    2a. Try connecting on an incognito browser tab.
  3. A proper shut down and restart of your computer

Did all that several times Sir ... execpt for 2a which I am uncertain what you mean.
I have multiple cleaners of several types and specific cleaning tasks .. PC could not get cleaner I do not think. And yes always reboot. And yes I use Firefox.

OK I accept its something to do with my PC maybe but I definitely do not know what it could be.

Seems odd to me that its my PC because MIT App Inventor works perfectly fine while does not. hmmmmm

ADDED NOTE: Back in December I had no problems. Sometimes difficulty connecting but not that often. By January I was having much difficulty. By February it was near impossible to connect.

I went on 10 week vacation and now I cant connect at all.

OK now I unpacked the portable version and have the same as you:

And then I do this:

And I do a localhost8888. The result is the same. I can NOT load my asset files.

Also :
I can not launch the cmd files from an exe.
I do not see a way to shut down the server

I'm still missing one screenshot, namely this one:

And let us know if your Windows OS is a 64 or 32 bit version.

1 Like