To do list stopped working

I copied some blocks from a to do list app by shloksingh1512, because I saw that his list worked, and when I replicated his list, mine worked too. However, that was yesterday, and today it stopped working, and sent an error message saying "Remove list item: Attempt to remove item 1 of an empty list", even though I made absolutely zero changes to the app. I went back to the original creator's app since I knew for sure his was unchanged, but it also didn't work. I asked my friend to simulate the app from the original creator, and the outcome was different for him than for me, since it didn't work, and it did for me on the first day of testing. These are my blocks and designer page for the original list. If there is an easier way to make a list, I would appreciate any help.image

Where is the place where you retrieve that data you saved in TinyDB?

In the ListView Component, use set element instead of elementsfromstring

1 Like

Try this.
I think you are missing out on calling the saved data into the ListView when u initialise the screen after the app is closed.

Thank you so much I haven't tried it but it makes a lot of sense.

Thank you so much, I'll add it right now, it makes sense.

Hope it works out for you

Ok I tried it and now it works perfectly, because it doesn't have brackets around it, but it only appears for a split second and then deletes the item in the list. even if you can't figure this one out I still appreciate fixing the primary problem a lot.

care to share ur aia file??

add this ....

I ammended the On ScreenInitialise blocs

yes hold on

k ill try it

When Screen Initialise Set the Global List to Get value from TinyDb and Set the List View Elements from Call Get Value from Tiny Db

It is workiing for me
Unless yoour requirement is at a variation !

1 Like

hmm why is it not working for me

Show ur blocks , or share ur aia

Like this?


Test.aia (2.6 KB)

how about you share your app to me and I try to copy some of my blocks over to compare everything easier

Test.aia (2.6 KB)

What? the same thing where it deletes after a split second is happening.

What is happenng?? You wanted to DELETE the List View Selection !