Syntax Error: quote in unquoted cell. Cannot parse text argument

Hello all,
Please help me.
I have a problem when download .csv file from google it just download size kb 1.08


Please see below post on how to ask a question to the forum

Also is your google file set to “Public - Anyone with Link can view" ?

As the error says, you have an unquoted quote in on of your cells. Review the content of your google sheet for characters like that.

Also see here for a range of issues:!searchin/mitappinventortest/unquoted|sort:date

Please have a look to my blocks and see if you can help me.
I have more than 200 .csv files, so the error message it comes sometimes when I download file by file. so I just give an example for .csv files type.
Example1.aia (56.1 KB)

Thank you

The issue lies in your google sheets contents, not in your blocks.

Hello Tim,

I tried to fix the blocks as I have seen in some posts.
But it download the .csv file kb 3.34
Kindly, help me to fix it.
Example_2.aia (56.4 KB)

Can you post the csv file please?

Here you are:
links.csv (567 Bytes)

Thank you so much for helping me

In your blocks, what component is Download?


It download .csv files. there are around 200 .csv files.
one example of them :
1.csv (973 Bytes)

Ok, but WHAT component is that? Where do I find it in the components palete? I don't remember seeing a Download component in App Inventor. Is it a listpicker or a listview?

Also, you say that's not the only CSV file you read. So, are you sure that's the CSV file where you get the error? Because I don't see anything wrong in it.

May be try adding quotes to each element?

Like this:

1 Like

Hello Italo,

I tried to add quotes but it doesn't work.download_1.aia (34.7 KB)

...The CSV files need to be edited to correct the fault, as per TIMAI2's example. You cannot fix a fault like that when importing the file.

Hello chrisWard,
Please give me the TIMAI2'S example for the CSV file. I will try to fix it.
Thank you a lot.

Your problem is most likely to be files that are saved with a BOM marker (non UTF-8) or you actually do have an extra quote in there somewhere which is breaking the csv format.

Identify the files that cause the error, ensure they are resaved in UTF-8 format without BOM, and check for formatting errors.

Hello Tim,
I couldn't find extra quote in .csv
Please help me dear Tim.
I attached the csv and please check it if you can solve my problem.
links.csv (567 Bytes)
Thank you a lot.

It is not that file that is the problem, is it? It is one of the files you are downloading within it.

Hello Tim,

I have checked all csv files and made new 50 csv files in order to see if it download or not but it download only kb 1.08
1.csv (83.8 KB)

Please Tim, see my csv file if you can solve my problem.
Thank so much Tim

That csv has over 5250 empty lines in it, probably doesn't help.

Try one of these, see if either will download in your app

1ab.csv (73.7 KB) 1a.csv (73.7 KB)