SharingTools Extension [Free & Open Source]

Okay now my head hurts because you confuse me. :sob:
And I keep my opinion because I have tried it with Real Device and it works 100% :triumph:

If you provide an aia example other developers can try the example that works on your phone and see if it works on their phone? Only if you both use exactly the same code can you determine why the extension 'does not work on' Anke's devices but it does work on yours. :slight_smile:

Then the score is 1 : 6. One works, six doesn't. :wink:

As I've said often enough, I would NEVER rely on just one test.

Okay, i will still thinking about it


okay this time I tested it for the 24th time in mit

This is impossible, I have tested it and you are right @Anke :cold_sweat: I'm so sorry mam
why can this happen, does MIT AI2 update the builder?
because I still remember I tested it on MIT AI2 and it worked :sob:

Here are Builder release notes

I tried.

With WhatsApp all 3 methods work.
With Messenger, Google Drive, Gmail works "ShareFile" and "ShareMessage".

Samsung S8, Android 9, Compiled apk and comanion.
I had to add File component to be able to admit the right to read files.

1 Like

hmm okay i have to try again using permission
can we talk privately @Anke @Patryk_F and @SteveJG

Yes, but Kodular works:

This is the same app (only using the full path: file:///storage/...).

I don't have Whatsapp and I never will, so I can't test it. But the Kodular version also works with Gmail, Email, Threema etc.

My test app asks for WRITE permission.
This doesn't change anything.

@Patryk_F Why should WRITE permission be required?

1 Like

I love that news :sweat_smile:

Wow I thought my extensions could only be on whatsapp :rofl: :sweat_smile:

yeah you are right, I think the problem is in AI2


The problem is that the extension does not contain annotations to add manifest permissions. Even when I add "AskForPermission", an error 908 pops up. However, in the App settings, there is no options at all to give file read permissions. Only the addition of File component enforces adding an annotation entering the manifest.

Okay guys, now i know the problem and I have checked my code again and I already feel that my code should be replaced with a more original one that works on all platforms,
so the latest update i will update it with new functions and fix SendMultipleFile bugs,
if i have time.
And I want to say a Big Thank You to @Anke because without her help I couldn't find this bugs.
Thank you very very very much @Anke :kissing_heart:

1 Like

its because i dont add that permission sir, that permission is not needed :smirk:

1 Like

Because no READ / WRITE permissions are required for this.

Download my APK from GD, install and open the app. This will copy the two image files to the external storage. Then remove storage permission from the app settings and try ...
So no READ / WRITE permissions are required.

1 Like

Fine, but does it really take that many posts to get there?

I conducted more tests in AI2. ShareMultipileFile method does not require permissions. It works with WhatsApp in AI2 without permissions. ShareFile method requires permission. Without permissions this method causes an error. And you're right. ShareMultleFile in the APP with Kodular also works with Google discs, in AI2, no. In Ai2 it work only in WhatsApp.

1 Like

Test the sharing of one file in AI2, because it does not work with your extension without permissions.

1 Like

Wht do u mean,
do you mean too many posts here?
if that is your point, I would like if there is a problem with the extensions,
we discuss it elsewhere, what do you think?