Recorder : In After recording event cannot get the sound

Following Is my source code.
In order to solve this issue

I specified the path for the recording folder. and no issue was raised when I clicked the start recording button.
But now I am getting an error saying error 701:Unable to load from the specified path.
Hope you can help me with this.
Thanking you in advance

The space in .../My Documents/... I am guessing is at index 78 in your file url

What happens if you do not specify a path for your saved recording?

You should also use the player component to playback your recordings. The sound component will only give a few seconds.

1 Like

When I don't give a path for savedRecording I am getting the error in the PIC I.e 802 when I click on start recording.

Actually earlier without specifying the path it was working fine. I have just started getting this error a couple days ago to which I made the change as mentioned above.


Sorry to bother.
But I am unable to get the call .AppSpecificDirectory. Can you direct me on how to get it?

1 Like

It's not working. This is the error I am getting.

Show your blocks and post the aia.

Which Android version and which device?

Android 5.1

I checked my blocks also on Android 5 and Android 5.1.
No issues, it works.

But on all devices I get this path:


Try this:

Thank you very much @Anke this worked for me.

I have another question is it necessary for the path to be /storage/emulated/....?
Can we not create an app directory specifically for the Recorder app ?

Actually this path /storage/emulated/0/ should work on all Android versions (but there might be something wrong with your device). I and my users have tested this on thousands of different devices and all Android versions. There were never any problems.

Of course, exactly what I did:

Actually previously the recorder app worked fine without giving the SavedRecording path. A couple of days ago it started giving the error. Is it because MIT app inventor has been updated?

I had the same prob too. It happened after app inventor version updated to nb187. I just hope MIT can fix it asap rather than using the workaround.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.