Problem with BLE in Android 11

Hi everyone.

I'm trying to make an app. It worked very well in the old versions of Android but doesn't work Android 11. I have updated the BluetoothLE extension.
ProblemI clicked to scan button and enter the list, but It does not show any device in the list. I am using the version 20200828 of BluetoothLE extension.
I did the all suggestions in these links but the problem was not solved.

Hello tugay katı

Ensure you have Location switched on before any BLE functions are called. Note that BLE requires 'fine' location, which seems to be the default in Android 11 but if your phone offers a choice, 'fine' is the one to choose.

In your case, the fault is clear from the error message - your App does not have permission to Access Bluetooth. That seems to be the case because the request has a typo. You can use the Classic Bluetooth Blocks to switch on Bluetooth:

Next time you want to show us your Blocks:
Right-mouse in the Blocks work area and select "Download Blocks as image"

Thanks Chris.
problem solved when my phone was given location permission

Also, the name of your permission is wrong. You need to ask for android.permission.Bluetooth. android.hardware.bluetooth_le is a constant used in the manifest to mark that the app needs that technology.