Problem with Anke's "Install apk from ASD extension"

I want to use @Anke 's Install APK extension.
She wrote DeepHost's download extension is not require permission to download specific directory so i use that.
I tried with original download path -android download directory-. Checking the download path showed that correctly.
Gave error:
Failed resolution of: Landroid/support/v4/content/FileProvider
I thouth its ok, because Install APK extension need the appspecific directory. I modified as in Anke's example. As the picture shows.
It gave the same error.
Checking the download path indeed created some specific path, but weirdly the file was ..../small.mp4.
What am i missing?

I found out there is a newer version of extension.
Why do there have to be so many libnk for one extension? Grrr.
Never mind. I will chek it in few minutes.

@Anke has used a support lib class which has been deprecated now so she (me too for PkgUtils extension) should use AndroidX lib.

P.S. Sounds good that she has already done it.

1 Like

Its not because of that.The update was because of The newer version is few monts old too.
I tried and didnt help, but it has a download method, i try it with that, but if you are right about the lib then it wont work either. Few minutes to try.

The extension is currently only intended for Kodular because, as @vknow360 said, the support lib is still used. See also here:

Well then, i have to look for an other solution.
Thank you for your answer.

Maybe this can help:

1 Like

But has this anything to do with this error?


There is a lot of difference between these two lines:



request.setDestinationInExternalPublicDir(dir, name);

The first one saves files in ASD while other saves file in external storage.
I got the solution from the SO link shared by you.

1 Like

@vknow360 Thank's, I'll check that later ...

1 Like

Looks like the same problem with Deep_Host's extension. It has an Open_Direct_file block that gives the same error.

For now, i solved the install problem with calling chrome and download with that and install after download, but waiting for some working extension. So far neither is working. I even tried KIO4_istall too.

By the way, if someone knows what preferences in activitystarter and permissions i have to set to be able to install from the app, that is also acceptable i think.

did you already try the install extension by @Juan_Antonio?

the activity starter solution, which was discussed here unfortunately does not work anymore for newer Android versions...


Trying to push the limits! Snippets, Tutorials and Extensions from Pura Vida Apps by Taifun.

Even if it works, it work from SDcard, that not have avery device. I need one that work from internal drive. From internal(default download dir)it gives the same error.

the extension from @Juan_Antonio should work from the internal (emulated) sdcard... as you said, it would not make much sense to offer an exension, which works only for external (removable) sdcards...


Ok. So, how can i create an emulated SDcard?

I think i got it. I give it a try.

No succes. Even i do it something wrong or it doesnt work on Internal.
By the way, it is an Android 9 device.

unfortunately without seeing your relevant blocks and without knowing what you are doing exactly nobody will be able to help...